Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000980graphvizBuild/Installpublic2005-10-02 11:152011-04-28 04:03
ReporterDanny Sadinoff 
Assigned Toellson 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOS*-*-OS Version
Summary0000980: passed-in perl executable not used when finding perl libs
Description



The perl install I have for daily use was linked statically,
so to take advantage of the perl linkage, I built a custom
perl, in /opt/newperl/perl-5.8.7/



The documentation would seem to indicate that the way to
use this custom perl (which is not in the path) is to do a



<CD>
 PERL=/opt/newperl/perl-5.8.7 ./configure
</CD>



if /usr/local/bin/perl is in the path, whose libdir is in
/opt/oldperl/lib,



...then the configure command above almost works.
The Makefile ends up containing:



<CD>
PERL = /opt/newperl/bin/perl
PERL_INCLUDES = -I/opt/oldperl/lib/5.8.0/sun4-solaris/CORE
PERL_LIBS = -L/opt/oldperl/perl-5.8.0/lib/5.8.0/sun4-solaris/CORE -lperl
</CD>



which points to the wrong perl install.
Additional Information

[ellson] Thank you very much for this.
I've applied your patch and the fix should be in tomorrow's snapshot.

TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT 
The bug is at line 394 of configure.ac, where the
discovered $PERL variable is unused.

Fix diff below.
<CD>
< PERL_ARCHLIB=`perl -e 'use Config; print $Config{archlib};'`
---

>> PERL_ARCHLIB=`$PERL -e 'use Config; print $Config{archlib};'`
</CD>

FORMER-ID801
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed (2 Oct 2005)
VERSION     2.6
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user695


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker