Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000964graphvizDotpublic2005-09-10 13:142011-04-28 04:03
ReporterMark RISON 
Assigned Toerg 
PrioritynormalSeveritycosmeticReproducibilityalways
StatusacknowledgedResolutionno change required 
PlatformOS*-*-OS Version
Summary0000964: Spurious PostScript nodecolor+filled in filled predefined shapes
Description



I have observed the following issue with filled nodes in PostScript
output mode:



There's a spurious 'nodecolor' before setting the fill colour, if the
(line) color attribute is passed, and there's a 'filled' which doesn't
actually do anything (see its definition):
<CD>
% node2a
gsave 10 dict begin
filled
0.000 1.000 1.000 nodecolor
0.667 1.000 1.000 nodecolor



% node3a
gsave 10 dict begin
filled
0.000 1.000 1.000 nodecolor
0.000 1.000 1.000 nodecolor
</CD>



but the spurious 'nodecolor' is not present if no (line) color
attribute is passed:



<CD>
% node4a
gsave 10 dict begin
filled
0.667 1.000 1.000 nodecolor
</CD>
Steps To Reproduce

digraph test
{
node2a [ shape = box, style = filled, fillcolor = blue, color = red ];
node3a [ shape = box, style = filled, color = red ];
node4a [ shape = box, style = filled, fillcolor = blue ];
}
Additional Information

[erg] The output is correct. This would fall in the category of an
optimization.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID785
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTRequest
VERSION     2.4 (Wed Jul 20 20:58:38 UTC 2005)
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker