Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000881graphvizDotpublic2005-04-25 04:422011-04-28 04:03
ReporterPaulo Pinto 
Assigned Toerg 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionno change required 
PlatformOSx86-Windows-XP SP2OS Version
Summary0000881: HTML labels don't accept latin characters
Description



Nodes with HTML labels will display the node name if the label contains latin characters.
See attached files for reproduction.
Command line:
  dot -Tpng bug_latin_html.txt -o bug_latin_html.png
<CD>
Error output:
  Error: not well-formed (invalid token) in line 2
  ... AndrÚ</td> ...
  in label of node node1
</CD>



I would expect this to work as I use the exact same character in a normal label, also demonstrated in the example file.
Additional Information

[erg] This is basically a request to officially support other character
sets than utf-8. For now, the user can use utf-8 or HTML encodings.
Note that if we allow a charset attribute, this should be passed into
libexpat.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID695
INPUT-FILEhttp://www.graphviz.org/bugs/b695.dot [^]
OUTPUT-FILEhttp://www.graphviz.org/bugs/b695.png [^]
STATUS-COMMENTRequest
VERSION     2.0
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker