Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000773graphvizDotpublic2007-08-31 13:242011-04-28 04:03
ReporterLaura Dietz 
Assigned Togviz 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOS*-Windows-XPOS Version
Summary0000773: more than 508 images inside htmllabels ==> No or improper image file
Description



I use a dot file containing nodes with html labels, where the label contains an <img src="D:\....\tmixNNNN.gif"> tag to embed the image inside the node's shape.



Usually, this works fine. But if I have many nodes I get the following error message for nodes in line numbers > 512 .oO( eh.. that number looks familiar )
<CD>
Warning: "D:\Dietz\hubcvs\phd\data\bugs-cites\image\tmix59813.gif" was not found
 as a file or as a shape library member
Error: No or improper image file="D:\Dietz\hubcvs\phd\data\bugs-cites\image\tmix
59813.gif"
in label of node 586107
</CD>



command line: dot -Tgif -ox.gif temp.dot



where temp.dot:



<CD>
digraph 624920 {
nodesep=0.4; ranksep=0.4;
size = "20,100";
ratio=compress;
470329[label = <<FONT POINT-SIZE="25"> <table border="0" width="50" ><tr border="0"><td border="0">470329 </td></tr><tr border="0"><td border="0">What Every Computer
Scientist Should
Know About ...
</td></tr><tr border="0"><td border="0"><img src="D:\Dietz\hubcvs\phd\data\bugs-cites\image\tmix65008.gif"></img></td></tr></table></FONT>>,shape=box,fillcolor=floralwhite,style="filled,rounded,setlinewidth(2)"];
693195[label = <<FONT POINT-SIZE="25"> <table border="0" width="50" ><tr border="0"><td border="0">693195 Blei,
Moreno </td></tr><tr border="0"><td border="0">Topic Segmentation
with an Aspect
Hidden Markov
... </td></tr><tr border="0"><td border="0"><img src="D:\Dietz\hubcvs\phd\data\bugs-cites\image\tmix65009.gif"></img></td></tr></table></FONT>>,shape=box,fillcolor=floralwhite,style="filled,rounded,setlinewidth(2)"];
..
</CD>



line no 513 (508'th node) causes the bug
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1184
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT*
VERSION     2.14
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker