Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000764graphvizOutput Generationpublic2007-08-23 03:332011-04-28 04:03
ReporterVishnu. M 
Assigned Toerg 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOS*-Linux-Fedora 5.0OS Version
Summary0000764: Problem in image creation using Graphviz
Description



I tried to implement the Graphviz with CGI.
I have installed the modules.
graphviz-2.14.1.tar.gz
webdot-2.10.tar.gz



I have used the library
use lib "/usr/local/lib/perl5/site_perl/5.8.8";
where the Graphviz module is located.
and include the GraphViz module using
use GraphViz;
For the image generation I have used the following code.



open(PICTURE, ">/var/www/html/images/picture.png") or die("Cannot open file for writing");
binmode PICTURE;
print PICTURE $g->as_png;
close PICTURE;



The image file is creating on the /var/www/html/images folder.
But my problem is that only the image file is creating. But no content
is there in the file.
Is the above code necessary for that..
Should I need to change any configuration in Apache or else?



Or



Is it the problem in the installation of the modules.
Webdot which is located in /root/graphviz-2.14/contrib/webdot.cgi
Will u help in solving this problem??
Comments;
[ryan] It seems to be a request for either more help with Perl, or specifically help with GraphViz.pm, neither of which the Graphviz team probably needs to be supporting.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1175
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed
VERSION     2.14
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker