Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000762graphvizDotpublic2007-08-21 05:402011-04-28 04:03
ReporterLi Long 
Assigned Toellson 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSx86-Linux-2.6.10-1.770_FC3OS Version
Summary0000762: cmd line "dot" w/ twopi messes up output when dealing with two graphs
Description



Cmd line is like:
<CD>
       dot -Tpng -Ktwopi -omyfile.png ex1.dot [ex2.dot]
</CD>
w/ only ex1.dot, it seems working ok,
with both ex1.dot and ex2.dot, there are lots of unprintable chars
output to the screen.



For ps, i.e., "...-Tps -omyfile.ps ...", it seems ok.
For svg, i.e., "...-Tsvg -omyfile.svg ...", there are outputs to
the screen as well.



It seems like the output engines don't respect '-o' option after
handling 1st graph.



FYI, my screen shot (part of):
<CD>
bash-3.00$ dot -Tpng -Ktwopi -oll_test.png ~/graphviz-2.14.1/graphs/directed/clust1.dot
bash-3.00$ dot -Tpng -Ktwopi -oll_test.png ~/graphviz-2.14.1/graphs/directed/clust1.dot ~/graphviz-2.14.1/graphs/directed/clust2.dot



\uffffPNG



IHDRU=\uffff"\uffff$PLTE\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff___???\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffff\uffffu%\uffff|[email protected]\uffff\ufffff\uffffIDATx\uffff\uffff\uffffAo\uffff6\uffff~\uffff\uffff\uffffV\[email protected]|,\uffff\[email protected]\uffff
\uffffC|
   \u0422\uffffo\u015a\U00077612:\uffff.\uffff\uffff\uffff\uffff\ufffffI\uffff%\uffff\uffffG\uffff\uffffIk\uffff<\uffff\uffff\uffff\uffff(\uffff\uffffG\uffff\uffff9\uffff\uffff\uffff3\uffffk\uffff\uffffl\uffff<a\uffff1\uffffs\uffffZ\uffff\u05b7`\uffff\uffff\u03daP\uffffE7\uffffm1\uffff\uffff-\uffff\uffff\uffff\uffff\uffff\uffffZP\uffffpy\uffff%\uffff\uffff\uffff\uffff\uffff+\uffff-rc\uffff4ml\uffff\uffffMI-v\uffff\uffff\uffffR\uffffk[p\uffff\u01ab\uffff\uffff\uffff\uffff&\uffffP\uffff\u06a6\uffffP
                                                           \uffffMU\uffff\uffffpm\uffff\uffff-~-\uffff\uffffO\uffff\uffff\uffff\uffff\uffff\uffff\uffff,\uffff~\uffff1\uffff+mQ?\uffff\uffffj\uffff\u01ad\uffffp²#ç\u240cÃÂŒÃÃ\u252c¯\\u2500ßW\u2409µÌϰò\u252cÃêáå÷»ëÃÃÞöî¯ÃÃÂ¥W°»YÃ.'Ã;ñ%ÃÃÁ\u240c·ÃÂŽ_÷!ÃÃ$û±šÎ;ßLÃOú_I¿.:^C¢ãڞ):Wåçë«\u25c6B­Y3­5¹Ã¶­VB÷Ãö\u240dÃ[­\u2510\u2510\u03c0²ÍŽÃ\u2534\u2265µH?€Ví\u240c°¹Ã'\u2409\u2592ö?°¢Ì¡6?\u250c,'\u2424\u250c:\u2424ÃTßà ÃDßà Ã\u2502ßÃ\u2424ßÃXß \u250c$ [email protected]ç\uffff\uffff\uffffb\uffff\uffff\uffffT\uffff\uffffX2\uffff,\uffff?\uffff\uffffChM\uffff\uffffC\uffff\u077bl\uffff\uffffBD\uffff\uffff\uffff\uffff\uffff\uffff\u04ef
\uffff\uffffY\uffff?\uffff\u05fe%\uffff\uffff\uffff\uffff+\uffffW\uffff:\uffff\uffff÷1\u03d6\uffff\uffffs\u01f2e\uffffP\uffff) \uffffJ{\uffff\uffff\uffff
..
</CD>
Additional Information

[ellson] The -Tpng format is not one that supports multiple images in the same file, so you need to provide a separate -o for each graph.

I think what is happenning is that the second is getting sent to stdout.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1173
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed (21 Aug 2007)
VERSION     2.14.1
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user695


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker