Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000638graphvizDotty/Lneato/Leftypublic2006-11-09 05:182011-04-28 04:03
ReporterRichard Berendsen 
Assigned Togviz 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOS*-Linux-ubuntu dapper drakeOS Version
Summary0000638: events get lost (right-click mouse menus not selectable)
Description



When I press the right mouse in dotty over a graph or a node, a context menu appears. I cant select anything, however. It will just disappear again when I release the button, even when Im over one of the items.



Earlier I already noticed that about half of the times I entered an attribute it would just disappear. It would not be set or anything, but also no error was given. But now, with the above bug, I can't use dotty at at all as a graph editor interface.
Steps To Reproduce

right mouse event
Additional Information

[erg] See also b524. Turning off the NUMLOCK fixes the problem.

[James Coleman (jamesc dspsrv.com)]
I also of course see this bug (solaris and cygwin).
I toggled num-lock and hey presto the menus work.
This behaviour is very puzzling and most new users would not find the very simple solution!

It should not matter about numlock.

dot version 2.2 (Wed Mar 23 14:44:07 UTC 2005)
 on cygwin

also:
dot version 1.10 (Wed Jan 5 16:56:31 GMT 2005)
 on solaris 10(sparc)
from sunfreeware.com package:
/usr/sbin/pkgchk -l -p `which dot`
        SFWgviz

both using cygwin as X server

I don't know X that well, but ...
Hmmm, well with truss -u (solaris - (truss -u a.out -u lib,libX*)) I can see that the menu is much quieter if numlock is on.
If mouse is scrolling in menu there is not X or user code activity.
If mouse is scrolling in menu with numlock off then there is activity (LOTS!).

Too much output to deal with but it would seem to be an X setup issue?
If numlock is on are the mouse events classed differently by X?
And are these event handlers not registered or initialised ... ?
Maybe a mask or flag at X App init time?

TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1042
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT*
VERSION     2.2.1
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker