Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000362graphvizDotpublic2004-03-29 00:002011-04-28 04:02
ReporterEckarath Khounsombath 
Assigned Toerg 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSWindows 200OS Version
Summary0000362: tmp.dot not showing in Dotty (loops)
Description



I generate a graph via Grappa library and i want to
have a nice display then I use dot exe to regenerate a
good graph with an beautiful layout but it's not working
it's returning me an empty layout. And when I try to display
my graph generated by Grappa via Dotty, it's not working.
Then I don't know if Grappa generated model not compliant with Dot
specification or generated model introduced an particular case or
I don't repect specification ?
Additional Information

[erg] This is actually a problem in dot handling loops.
At present, there are about a dozen related bugs:
57, 73, 74, 76, 88, 122, 163, 183, 247, 275, 290, 291, 394.

[ellson] This seems to be a problem with self-edges between record fields in the
same node.

Specifically, either of these two edges cause dot to abort.
<CD>
TIME_3:t1 -> TIME_3:t2 [ label = 4 ];
TIME_6:t1 -> TIME_6:t2 [ label = 7 ];
</CD>

With both commented dot does not abort.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID426
INPUT-FILEhttp://www.graphviz.org/bugs/b426.dot [^]
OUTPUT-FILE
STATUS-COMMENTFixed (4 Mar 2005)
VERSION   Graphviz 1.12
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:02 user1 New Issue
2011-04-28 04:02 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker