Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000314graphvizDotty/Lneato/Leftypublic2003-11-26 12:002011-04-28 04:02
ReporterRob2 
Assigned Togviz 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSx86-Windows-XP (SP1)OS Version
Summary0000314: Cluster background colours (style filled; color) do not work
Description



Dotty does not seem to take any notice of the combined commands
<CD>
  style=filled;
  color=lightgrey; /* or whatever */
</CD>
in a "cluster" subgraph.



In particular, I have tried (by direct copy & paste) the specific example "Figure 15: Process diagram with clusters" in dotguide.pdf (4 Feb 2002).



A cluster's bounding box always seems to be in outline rather than filled, with the colour applying to the line rather than the background.
Steps To Reproduce

digraph G {
  subgraph cluster0 {
    node_1 [label="hello"];
    style=filled;
    color=grey;
  }
}

Another example: your "Process diagram with clusters"
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID383
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed (12 April 2005)
VERSION     1.10
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:02 user1 New Issue
2011-04-28 04:02 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker