Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002540graphvizTcl/Tk Utilitiespublic2015-04-23 02:362015-04-23 02:36
ReporterBob Diertens 
Assigned To 
PriorityurgentSeveritycrashReproducibilityalways
StatusnewResolutionopen 
PlatformOSLinuxOS Version3.6
Summary0002540: tcldot crashes with version higher than 2.28
DescriptionTcldot crashes either with a segmentation fault or with the message
wish8.6: emit.c:3899: init_splines_bb: Assertion `spl->size > 0' failed.
Abort
This happens with all version of graphviz above 2.28
Steps To Reproducepackage require Tcldot

wm title . "Fluid"
set w .g

set c [canvas $w -bd 0]
pack $c

set g [dotnew digraph rankdir LR]

$g addnode nx
$g layout
eval [$g render]
update
$g addnode n1
$g addnode n2
$g addedge n1 n2 label "e"
$c delete all
update
$g layout
eval [$g render]
Additional InformationTcldot is used in the lab-sessions for students of the University of Amsterdam.
Although the lab machines are equipped with working installation, the students
use their laptops. The laptops installation usually have the higher version
of the packages available. Most of the students have trouble downgrading it
to a working installation.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.30 and higher
Attached Files? file icon myfluid (Attachment missing)

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2015-04-23 02:36 Bob Diertens New Issue
2015-04-23 02:36 Bob Diertens File Added: myfluid


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker