Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002481graphvizDotpublic2014-08-19 07:332015-04-02 08:47
ReporterPeter Suter 
Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
PlatformOSWindowsOS Version
Summary0002481: PDF output missing text and edges if node fillcolor is a gradient
DescriptionDot generates PDF's that are missing all labels and edges, and just shows the nodes, if the nodes are filled with a gradient.

The same graph works fine with PNG output format, or if a constant color is used instead of a gradient.
Steps To ReproduceCreate a simple test.dot:

graph g {
    node [style=filled, fillcolor="red:blue" ];
    bug--error;
}

Run:
    dot -Tpng -otest.png test.dot
    dot -Tpdf -otest.pdf test.dot

Open the test.png file and see the expected labels and edge.
Open the test.pdf file and note the labels and edge are missing!
Additional Information(For more "complex" graphs, PDF output with gradients seems to work. E.g. after adding a subgraph cluster all labels and edges appear correctly:)
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.38
Attached Filespdf file icon test.pdf (Attachment missing)
png file icon test.png (Attachment missing)
png file icon test-pdf.png (Attachment missing)

- Relationships

-  Notes
User avatar (0000808)
Peter Suter (reporter)
2014-09-04 03:10
edited on: 2014-09-04 03:11

This bug did not exist in 2.30.1

User avatar (0000809)
Peter Suter (reporter)
2014-09-05 03:26

2.32 and 2.34 are also OK.
The bug first appeared in 2.36.
User avatar (0000815)
Peter Suter (reporter)
2014-09-11 08:34

I can also confirm that this regression is still reproducable with the steps mentioned above in the current development snapshot graphviz-2.39.20140911
User avatar (0000822)
Peter Suter (reporter)
2014-09-19 09:39

On Linux (Ubuntu) (with "dot - graphviz version 2.39.20140919.0445 (20140919.0445)") I can not reproduce the problem.

It's still there on Windows though (also "dot - graphviz version 2.39.20140919.0445 (20140919.0445)").
User avatar (0000848)
Peter Suter (reporter)
2014-11-03 08:17

> Additional Information: For more "complex" graphs, PDF output with gradients seems to work. E.g. after adding a subgraph cluster all labels and edges appear correctly:

graph g {
    node [style=filled, fillcolor="red:blue"];
    bug--error;
    subgraph cluster1 {
        error--clusterfix;
    }
}
User avatar (0000859)
Peter Suter (reporter)
2014-12-19 05:09

graphviz-2.39.20141219 is still broken.
User avatar (0000922)
Peter Suter (reporter)
2015-04-02 08:47

graphviz-2.39.20150331 is still broken.

- Issue History
Date Modified Username Field Change
2014-08-19 07:33 Peter Suter New Issue
2014-09-04 03:10 Peter Suter Note Added: 0000808
2014-09-04 03:11 Peter Suter Note Edited: 0000808 View Revisions
2014-09-05 03:26 Peter Suter Note Added: 0000809
2014-09-11 08:34 Peter Suter Note Added: 0000815
2014-09-19 09:39 Peter Suter Note Added: 0000822
2014-09-25 11:25 Peter Suter File Added: test.pdf
2014-09-25 11:27 Peter Suter File Added: test.png
2014-10-03 07:02 Peter Suter File Added: test-pdf.png
2014-11-03 08:17 Peter Suter Note Added: 0000848
2014-12-19 05:09 Peter Suter Note Added: 0000859
2015-04-02 08:47 Peter Suter Note Added: 0000922


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker