Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002468graphvizDotpublic2014-07-06 16:492014-07-06 16:49
Reporterodbo 
Assigned To 
PrioritynormalSeverityimportantReproducibilityalways
StatusnewResolutionopen 
PlatformWindows 7OSWindows 7OS Versionx64
Summary0002468: imagepath not wotking as expected in svg output
Descriptionimagepath is not output to svg file

Steps To Reproduceassuming current directory = "c:\data", "c:\temp\icons\page.gif" exists, graph file graph.gv

The following render fine:
"c:\Program Files (x86)\Graphviz2.38\bin\dot.exe" -Tpng -ograph.png graph.gv

digraph{
    imagepath="icons"
    a[label=<<table><tr><td><img src="page.gif"/></td></tr></table>>]
}

but this render a graph with unresolved images (shows as blank in IE11 and Chrome):
"c:\Program Files (x86)\Graphviz2.38\bin\dot.exe" -Tsvg -ograph.svg graph.gv

(same graph as above)
Additional Informationit is still checked if the images are at the specified imagepath
The following will fail for both png and svg:

digraph{
    //imagepath="icons"
    a[label=<<table><tr><td><img src="page.gif"/></td></tr></table>>]
}

Warning: No such file or directory while opening page.gif
Error: No or improper image file="page.gif"
in label of node a
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.38
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2014-07-06 16:49 odbo New Issue


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker