Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002404graphvizGraph Librariespublic2013-12-16 17:222013-12-24 17:17
Reporterryandesign 
Assigned Toellson 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platformx86_64OSOS XOS Version10.8.5
Summary0002404: #define WITH_CGRAPH was removed
Descriptionroot 5.34.14 builds successfully with graphviz 2.34.0 but not with 2.35.20131214.0545. See:

https://trac.macports.org/ticket/41454 [^]

This was reported to the developers of root:

https://sft.its.cern.ch/jira/browse/ROOT-5784 [^]

It seems root is using the define WITH_CGRAPH to determine whether to use libcgraph or libgraph, but this define was recently removed from Graphviz. Can this define be put back in, or is there another way that other developers should figure out whether to use libcgraph or libgraph?
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.35.20131214.0545
Attached Files

- Relationships

-  Notes
User avatar (0000651)
erg (administrator)
2013-12-17 20:45

The #define was replaced in config.h. Note that as of 2.35, it is always true, as it is the only choice, and it is not used in the Graphviz source. Unless an application has to remain viable with an old version of Graphviz using the original graph library, uses of WITH_CGRAPH can be removed.
User avatar (0000657)
ryandesign (reporter)
2013-12-23 02:46

I assume 88057b7be163f35c0a09cbb24d45283a5b93bd9a was intended to fix this, however it doesn't appear to have done so. With graphviz 2.35.20131223.0545 there is still no WITH_CGRAPH defined in any file installed by graphviz.
User avatar (0000658)
erg (administrator)
2013-12-23 09:47

Okay, WITH_CGRAPH should now be back in include/graphviz/types.h.
User avatar (0000659)
ryandesign (reporter)
2013-12-24 17:12

Thanks, that fixes it.

- Issue History
Date Modified Username Field Change
2013-12-16 17:22 ryandesign New Issue
2013-12-17 20:45 erg Note Added: 0000651
2013-12-17 20:45 erg Assigned To => ellson
2013-12-17 20:45 erg Status new => resolved
2013-12-17 20:45 erg Resolution open => fixed
2013-12-23 02:46 ryandesign Note Added: 0000657
2013-12-23 02:46 ryandesign Status resolved => feedback
2013-12-23 02:46 ryandesign Resolution fixed => reopened
2013-12-23 09:47 erg Note Added: 0000658
2013-12-24 17:12 ryandesign Note Added: 0000659
2013-12-24 17:12 ryandesign Status feedback => assigned
2013-12-24 17:17 erg Status assigned => resolved
2013-12-24 17:17 erg Resolution reopened => fixed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker