Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002393graphvizOutput Generationpublic2013-11-25 22:432013-12-05 14:06
Reporterryandesign 
Assigned Toerg 
PrioritylowSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platformx86_64OSOS XOS Version10.8.5
Summary0002393: xdot background polygon coordinates are "nan" with no nodes
DescriptionThis graph should make a 72px ✕ 72px red canvas with no nodes, and that is what the PNG output shows. But the xdot output shows:

_draw_="c 7 -#ff0000 C 7 -#ff0000 P 4 nan nan nan nan nan nan nan nan "
Steps To Reproducedot nan.gv -Txdot -onan.gv.xdot -Tpng -onan.gv.png
Additional InformationThis may be because of the difference in default pad values for PNG and xdot output. As I recently learned, the default pad for PNG is 4 but the default for xdot is 0. If I add "pad=0" to the graph, then the PNG output doesn't work either (graphviz generates a 0-byte PNG file).
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.35.20131122.0545
Attached Files? file icon nan.gv [^] (45 bytes) 2013-11-25 22:43
? file icon nan.gv.xdot [^] (187 bytes) 2013-11-25 22:43
png file icon nan.gv.png [^] (182 bytes) 2013-11-25 22:43

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-11-25 22:43 ryandesign New Issue
2013-11-25 22:43 ryandesign File Added: nan.gv
2013-11-25 22:43 ryandesign File Added: nan.gv.xdot
2013-11-25 22:43 ryandesign File Added: nan.gv.png
2013-12-05 14:06 erg Assigned To => erg
2013-12-05 14:06 erg Status new => resolved
2013-12-05 14:06 erg Resolution open => fixed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker