Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002381graphvizBuild/Installpublic2013-10-07 20:282013-10-08 08:27
Reportersade 
Assigned Toellson 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
PlatformRedhat ELOSLinuxOS Version5.9
Summary0002381: Missing Dependency: libANN.so.1()(64bit) is needed by package graphviz-2.34.0-1.el5.x86_64 (graphviz-stable)
DescriptionHi, I am facing the following error on a rhel 5.9. glibc-2.5-107.el5_9.5 is installed on the server. Please advise ASAP as this is on our very important server and needs to be looked into soon.

This error comes when i run a yum update on my linux system.

--------------------------------------------------------------------------------
graphviz-2.34.0-1.el5.x86_64 from graphviz-stable has depsolving problems
  --> Missing Dependency: libANN.so.1()(64bit) is needed by package graphviz-2.34.0-1.el5 .x86_64 (graphviz-stable)
--> Running transaction check
---> Package graphviz.x86_64 0:2.34.0-1.el5 set to be updated
--> Processing Dependency: libANN.so.1()(64bit) for package: graphviz
---> Package kernel.x86_64 0:2.6.18-348.3.1.el5 set to be erased
--> Finished Dependency Resolution
graphviz-2.34.0-1.el5.x86_64 from graphviz-stable has depsolving problems
  --> Missing Dependency: libANN.so.1()(64bit) is needed by package graphviz-2.34.0-1.el5 .x86_64 (graphviz-stable)
Error: Missing Dependency: libANN.so.1()(64bit) is needed by package graphviz-2.34.0-1.el 5.x86_64 (graphviz-stable)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

--------------------------------------------------------------------------------
Graphviz repo is configured as follows:

[graphviz-stable]
name=Graphviz - RHEL $releasever - $basearch
baseurl=http://www.graphviz.org/pub/graphviz/stable/redhat/el$releasever/$basearch/os/ [^]
enabled=1
gpgcheck=0

[graphviz-stable-source]
name=Graphviz - RHEL $releasever - Source
baseurl=http://www.graphviz.org/pub/graphviz/stable/SRPMS/ [^]
enabled=0
gpgcheck=0

[graphviz-stable-debuginfo]
name=Graphviz - RHEL - Debug
baseurl=http://www.graphviz.org/pub/graphviz/stable/redhat/el$releasever/$basearch/debug/ [^]
enabled=0
gpgcheck=0

[graphviz-snapshot]
name=Graphviz - RHEL $releasever - $basearch
baseurl=http://www.graphviz.org/pub/graphviz/development/redhat/el$releasever/$basearch/os/ [^]
enabled=0
gpgcheck=0

[graphviz-snapshot-source]
name=Graphviz - RHEL $releasever - Source
baseurl=http://www.graphviz.org/pub/graphviz/development/SRPMS/ [^]
enabled=0
gpgcheck=0

[graphviz-snapshot-debuginfo]
name=Graphviz - RHEL - Debug
baseurl=http://www.graphviz.org/pub/graphviz/development/redhat/el$releasever/$basearch/debug/ [^]
enabled=0
gpgcheck=0
Steps To Reproducereran yum update and ran yum install graphviz separately.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENTneeds EPEL repo for ANN dependency
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION
Attached Files

- Relationships

-  Notes
User avatar (0000561)
sade (reporter)
2013-10-07 20:44

Graphviz Product version graphviz-2.32.0-1.el5
User avatar (0000563)
ellson (administrator)
2013-10-08 08:26

The ANN dependency can be satisfied from the EPEL repo.

    http://fedoraproject.org/wiki/EPEL [^]

- Issue History
Date Modified Username Field Change
2013-10-07 20:28 sade New Issue
2013-10-07 20:44 sade Note Added: 0000561
2013-10-08 08:26 ellson Note Added: 0000563
2013-10-08 08:27 ellson FIX-COMMENT => needs EPEL repo for ANN dependency
2013-10-08 08:27 ellson Status new => resolved
2013-10-08 08:27 ellson Resolution open => fixed
2013-10-08 08:27 ellson Assigned To => ellson


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker