Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002362graphvizBuild/Installpublic2013-09-09 16:242013-09-09 16:24
Reportertk 
Assigned To 
PrioritynormalSeveritynormalReproducibilityalways
StatusnewResolutionopen 
PlatformOSOS Version
Summary0002362: sh problems in configure script
DescriptionThere are two constructs in the configure script that break running it on NetBSD with /bin/sh:

The part where the graphviz version number is built, and the part where the platformsdk is escaped.

Without the first chunk, configure dies with:
./configure.lineno: 1: Syntax error: Bad substitution
The shell code for this is from [email protected].

I don't have an interest in platformsdk, so I just removed that part of the configure script:

@@ -27212,11 +27220,6 @@ fi
 
 
 
-# Check whether --with-platformsdkincludedir was given.
-if test "${with_platformsdkincludedir+set}" = set; then :
- withval=$with_platformsdkincludedir; PLATFORMSDKINCLUDE=$withval; PLATFORMSDKINCLUDE_ESCAPED=${PLATFORMSDKINCLUDE//'\\'/\\\\}; PLATFORMSDKINCLUDE_ESCAPED=${PLATFORMSDKINCLUDE_ESCAPED// /\\ }
-fi
-
 
 
 # Check whether --with-platformsdklibdir was given.

Without this, I get:
./configure.lineno: 27203: Syntax error: Bad substitution
Steps To ReproduceRun configure with /bin/sh on NetBSD.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.34.0
Attached Filesdiff file icon configure-ac.diff [^] (1,174 bytes) 2013-09-09 16:24 [Show Content]

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2013-09-09 16:24 tk New Issue
2013-09-09 16:24 tk File Added: configure-ac.diff


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker