Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002353graphvizGraph Librariespublic2013-09-04 06:032013-09-05 14:04
Reporterphisama 
Assigned Toerg 
PrioritynormalSeveritynormalReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSopenSUSEOS Version12.3
Summary0002353: cdt sources use the wrong define for proper prototypes
DescriptionThe sources in cdt erroneously trigger on __STD_C being defined to use proper prototypes while the correct symbol is __STDC__. This patch changes this.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION
Attached Filespatch file icon graphviz-proper_prototypes.patch [^] (8,644 bytes) 2013-09-04 06:03 [Show Content]

- Relationships

-  Notes
User avatar (0000483)
erg (administrator)
2013-09-04 15:51

Actually, the authors of cdt chose to use their own version because of the variability of the standard:

"__STD_C is defined in the iffe-generated FEATURE/common => ast_common.h
we did that a long time ago because although the symbol __STDC__ is standard
its values are not standard
there's all sorts of weird #if logic in the wild differentiating between
__STDC__ == 0 vs __STDC__ == 1 vs __STDC__ not defined vs maybe other values
we dispensed with that in one place and used __STD_C consistently."

The macro __STD_C is set in ast_common.h, which we need to include in cdt as we currently do in vmalloc and sfio.
User avatar (0000490)
phisama (reporter)
2013-09-05 11:30

So is this the right fix to dthdr.h:

#if _PACKAGE_ast
#include <ast.h>
#else
#include <ast-common.h>
#endif
User avatar (0000492)
erg (administrator)
2013-09-05 11:38

That is what I added to dthdr.h (except for the misspelling of ast_common.h).
User avatar (0000493)
phisama (reporter)
2013-09-05 12:04

Yeah, that typo isn't in the patch I use until the next release. So this can be closed.

- Issue History
Date Modified Username Field Change
2013-09-04 06:03 phisama New Issue
2013-09-04 06:03 phisama File Added: graphviz-proper_prototypes.patch
2013-09-04 15:51 erg Note Added: 0000483
2013-09-04 15:51 erg Assigned To => erg
2013-09-04 15:51 erg Status new => resolved
2013-09-04 15:51 erg Resolution open => fixed
2013-09-05 11:30 phisama Note Added: 0000490
2013-09-05 11:30 phisama Status resolved => feedback
2013-09-05 11:30 phisama Resolution fixed => reopened
2013-09-05 11:38 erg Note Added: 0000492
2013-09-05 12:04 phisama Note Added: 0000493
2013-09-05 12:04 phisama Status feedback => assigned
2013-09-05 14:04 erg Status assigned => closed
2013-09-05 14:04 erg Resolution reopened => fixed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker