Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002352graphvizGraph Librariespublic2013-09-04 05:582014-03-21 15:34
Reporterphisama 
Assigned Toerg 
PrioritynormalSeveritynormalReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSopenSUSEOS Version12.3
Summary0002352: Declarations missing in cdt.h
Descriptioncdt.h lacks declarations for dtstat and dtstrhash. The attached patch adds tem.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENTsee note
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION
Attached Filespatch file icon graphviz-missing_headers.patch [^] (746 bytes) 2013-09-04 05:58 [Show Content]

- Relationships

-  Notes
User avatar (0000479)
erg (administrator)
2013-09-04 10:37

This one is confusing. It claims that declarations are missing but they are there, and the patch only adds #include <string.h> and gets rid of two
ad hoc declarations.

The proper change is probably to get rid of
-#if !_PACKAGE_ast
-extern int memcmp _ARG_((const Void_t*, const Void_t*, size_t));
-extern int strcmp _ARG_((const char*, const char*));
-#endif
-

as in the patch and add

#ifdef HAVE_STRING_H
#include <string.h>
#else
extern int memcmp _ARG_((const Void_t*, const Void_t*, size_t));
extern int strcmp _ARG_((const char*, const char*));
#endif

after #include <stddef.h>
User avatar (0000484)
erg (administrator)
2013-09-04 15:52

I made the changes suggested in my previous note.
User avatar (0000715)
erg (administrator)
2014-03-21 15:34

Mea culpa. I should have just used the original patch, since HAVE_STRING_H works internally, but not for an exported .h file.

- Issue History
Date Modified Username Field Change
2013-09-04 05:58 phisama New Issue
2013-09-04 05:58 phisama File Added: graphviz-missing_headers.patch
2013-09-04 10:37 erg Note Added: 0000479
2013-09-04 15:52 erg Note Added: 0000484
2013-09-04 15:52 erg Assigned To => erg
2013-09-04 15:52 erg Status new => resolved
2013-09-04 15:52 erg Resolution open => fixed
2013-09-07 13:26 ellson FIX-COMMENT => see note
2013-09-07 13:26 ellson Status resolved => closed
2014-03-21 15:34 erg Note Added: 0000715


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker