Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002325graphvizBuild/Installpublic2013-08-09 22:492013-09-07 13:17
Reporterryandesign 
Assigned Toellson 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSOS XOS Version10.8.4
Summary0002325: configure: "linker input file unused because linking not done"
DescriptionConfiguring graphviz with "-Wl,-headerpad_max_install_names" in LDFLAGS results in this warning:

checking if assert needs __eprintf... i686-apple-darwin11-llvm-gcc-4.2: -headerpad_max_install_names: linker input file unused because linking not done
no
Steps To ReproduceLDFLAGS="-Wl,-headerpad_max_install_names" ./configure
Additional InformationThis bug was originally reported to the MacPorts project: https://trac.macports.org/ticket/40056 [^]

As of MacPorts 2.2, which was recently released, "-Wl,-headerpad_max_install_names" is automatically added to the LDFLAGS, in order that our ports might compile their libraries so that they are relocatable: https://trac.macports.org/ticket/29838 [^]
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENTdarwin LDFLAG added to configure.ac, removed LDFLAGS in eprintf test
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.33.20130802.0446
Attached Filesdiff file icon configure.ac.diff [^] (397 bytes) 2013-09-06 18:37 [Show Content]

- Relationships

-  Notes
User avatar (0000487)
ellson (administrator)
2013-09-05 10:38

Added to configure.ac for darwin only. Not yet tested. Should be in tonight's build.
User avatar (0000498)
ryandesign (reporter)
2013-09-06 18:36
edited on: 2013-09-06 18:38

Thanks for adding -Wl,-headerpad_max_install_names to the LDFLAGS by default on Darwin; that will help users who are not using MacPorts if they want Graphviz to be relocatable. But that doesn't fix the unnecessary warning message that this bug report was about, which was that when -Wl,-headerpad_max_install_names is in LDFLAGS, then this message occurs:

checking if assert needs __eprintf... i686-apple-darwin11-llvm-gcc-4.2: -headerpad_max_install_names: 
linker input file unused because linking not done
no


That's what our user was reporting to us in our issue 40056. Our user found that this part of the configure.ac file was responsible:

AC_MSG_CHECKING(if assert needs __eprintf)
cat > conftest.$ac_ext <<EOF
#include "confdefs.h"
#include "assert.h"
int main(int argc, char **argv) {
assert(argc);
; return 0; }
EOF
${CC-cc} -c $CFLAGS $CPPFLAGS $LDFLAGS conftest.$ac_ext 1>&5
if test "x`nm conftest.o |$EGREP __eprintf`" != "x"; then
    AC_MSG_RESULT(yes)
    CFLAGS="$CFLAGS -DNDEBUG"
else
    AC_MSG_RESULT(no)
fi
rm -f conftest*


The manpage for gcc says the -c option means "Compile or assemble the source files, but do not link." The clang manpage says similarly. In that case, I think $LDFLAGS should not be included there, and removing it does remove the warning message.


- Issue History
Date Modified Username Field Change
2013-08-09 22:49 ryandesign New Issue
2013-09-05 10:38 ellson Note Added: 0000487
2013-09-05 10:39 ellson FIX-COMMENT => darwin LDFLAG added to configure.ac
2013-09-05 10:39 ellson Status new => resolved
2013-09-05 10:39 ellson Resolution open => fixed
2013-09-05 10:39 ellson Assigned To => ellson
2013-09-06 18:36 ryandesign Note Added: 0000498
2013-09-06 18:36 ryandesign Status resolved => feedback
2013-09-06 18:36 ryandesign Resolution fixed => reopened
2013-09-06 18:37 ryandesign File Added: configure.ac.diff
2013-09-06 18:38 ryandesign Note Edited: 0000498 View Revisions
2013-09-06 18:38 ryandesign Note Edited: 0000498 View Revisions
2013-09-06 21:36 ellson FIX-COMMENT darwin LDFLAG added to configure.ac => darwin LDFLAG added to configure.ac, removed LDFLAGS in eprintf test
2013-09-06 21:36 ellson Status feedback => resolved
2013-09-06 21:36 ellson Resolution reopened => fixed
2013-09-07 13:17 ellson Status resolved => closed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker