Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002322graphvizBuild/Installpublic2013-08-05 09:242013-09-07 13:29
ReporterJaroslav Skarvada 
Assigned Toellson 
PrioritynormalSeveritynormalReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0002322: Perl config uses depracated qw construct that was removed in perl 5.18
DescriptionThe config_perl.pl uses the following construct:

  foreach $d qw(installvendorarch vendorarch installsitearch sitearch) {

This is deprecated in latest perl interpreters and results in the following warning:

> Use of qw(...) as parentheses is deprecated at ./test.pl line 17.

Moreover it seems this construct was removed from perl-5.18 and this construct will result in syntax error which will cause build failure.
Steps To ReproduceBuild with perl-5.18:

checking for perl... perl
syntax error at ./config/config_perl.pl line 17, near "$d qw(installvendorarch vendorarch installsitearch sitearch)"
syntax error at ./config/config_perl.pl line 22, near "}"
Execution of ./config/config_perl.pl aborted due to compilation errors.
syntax error at ./config/config_perl.pl line 17, near "$d qw(installvendorarch vendorarch installsitearch sitearch)"
syntax error at ./config/config_perl.pl line 22, near "}"
Execution of ./config/config_perl.pl aborted due to compilation errors.
syntax error at ./config/config_perl.pl line 17, near "$d qw(installvendorarch vendorarch installsitearch sitearch)"
syntax error at ./config/config_perl.pl line 22, near "}"
Execution of ./config/config_perl.pl aborted due to compilation errors.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSIONgraphviz-2.30.1
Attached Filespatch file icon graphviz-2.30.1-perl-fix.patch [^] (577 bytes) 2013-08-05 09:24 [Show Content]

- Relationships

-  Notes
User avatar (0000424)
ellson (administrator)
2013-08-05 10:18

Patch applied. Thank you.

- Issue History
Date Modified Username Field Change
2013-08-05 09:24 Jaroslav Skarvada New Issue
2013-08-05 09:24 Jaroslav Skarvada File Added: graphviz-2.30.1-perl-fix.patch
2013-08-05 10:18 ellson Note Added: 0000424
2013-08-05 10:27 erg Assigned To => ellson
2013-08-05 10:27 erg Status new => resolved
2013-08-05 10:27 erg Resolution open => fixed
2013-09-07 13:29 ellson Status resolved => closed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker