Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002316graphvizDotpublic2013-07-29 02:212013-07-30 21:02
Reporterryandesign 
Assigned Toerg 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformx86_64OSOS XOS Version10.8.4
Summary0002316: This graph crashes dot
DescriptionThis graph crashes dot. It didn't crash dot earlier this month.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.31.20130729.0446
Attached Files? file icon graph3.gv [^] (225 bytes) 2013-07-29 02:21
? file icon dot_2013-07-29-011902_poppins.crash [^] (35,147 bytes) 2013-07-29 02:21

- Relationships

-  Notes
User avatar (0000402)
ellson (administrator)
2013-07-29 10:34

Appears to be specific to OS-X. Works-for-me on Linux.

Graph uses ortho, and alpha for semi-transparent colors.

Does "dot graph3.gv" crash? (i.e. is it layout or renderer that cashes?)
User avatar (0000404)
ryandesign (reporter)
2013-07-29 13:37

"dot graph3.gv" crashes also. There is no crash if I remove "splines=ortho". I have had crashes with other graphs with splines=ortho before, but this graph has not been edited since January 2012 and has worked fine until some time this month.
User avatar (0000410)
erg (administrator)
2013-07-30 15:21

It was a memory problem that affected all versions. Mountain Lion just brought it into the open. At least, I believe it is fixed. I will check this evening on Mountain Lion to be sure.
User avatar (0000411)
erg (administrator)
2013-07-30 21:02

I tested the original graph on Mountain Lion and all seems to be fine.

- Issue History
Date Modified Username Field Change
2013-07-29 02:21 ryandesign New Issue
2013-07-29 02:21 ryandesign File Added: graph3.gv
2013-07-29 02:21 ryandesign File Added: dot_2013-07-29-011902_poppins.crash
2013-07-29 10:34 ellson Note Added: 0000402
2013-07-29 13:37 ryandesign Note Added: 0000404
2013-07-30 15:21 erg Note Added: 0000410
2013-07-30 15:21 erg Assigned To => erg
2013-07-30 15:21 erg Status new => resolved
2013-07-30 15:21 erg Resolution open => fixed
2013-07-30 21:02 erg Note Added: 0000411
2013-07-30 21:02 erg Status resolved => closed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker