Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002294graphvizOutput Generationpublic2013-06-10 04:282013-10-21 02:52
Reportervalexiev 
Assigned Toerg 
PrioritynormalSeveritycriticalReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Summary0002294: large HTML labels: very slow and too much space
DescriptionLarge HTML labels (tables) have two problems:

1. Take a lot of time to generate. This command takes over 3 minutes
dot -Tsvg graph2.gv -o graph2.svg
Same happens for PNG and SVG output.

2. Add too much horizontal space between the columns (see graph2.svg)

This is with the latest stable version and the latest snapshot, on Windows7 (and I'm pretty sure also on Linux).

I attach a test case (graph2.gv) and the corresponding output (graph2.svg and png)
Tagshtml-label
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.31.20130602.0447
Attached Files? file icon graph2.gv [^] (10,575 bytes) 2013-06-10 04:29
png file icon graph2.png [^] (123,649 bytes) 2013-06-10 04:30


? file icon graph2.svg [^] (30,948 bytes) 2013-06-10 04:30
? file icon html-label-bug.gv [^] (2,957 bytes) 2013-06-10 04:58
png file icon html-label-bug.png [^] (21,257 bytes) 2013-06-10 04:58

- Relationships

-  Notes
User avatar (0000356)
valexiev (reporter)
2013-06-10 05:01

html-label-bug.gv is a minimal test case: a single node.
Processing it takes 2:10 minutes on Intel i5 2.67 GHz (4 cores, but gv uses 1 core) with this command:
dot -Tpng html-label-bug.gv -o html-label-bug.png
User avatar (0000564)
erg (administrator)
2013-10-10 16:45

I agree about the excess horizontal space. I'll look into it. On the other hand, the performance problem on Windows has been fixed. If you get a working version dated 11 October or later, this should be fixed. (Note: our machines are moving tonight, so it may be day or two when the new version is available.)
User avatar (0000566)
valexiev (reporter)
2013-10-14 09:03

I've tried with graphviz-2.34.msi and graphviz-2.35.20131014.msi on Windows7 x64 (with both files), and it again takes a long time to process, and makes the tables too wide
User avatar (0000567)
erg (administrator)
2013-10-14 11:04

2.34 won't change. Any fixes will only go into the working version. Alas, despite the name on the file graphviz-2.35.20131014.msi, this is the 10 October version as you can verify by running dot -V, so the fixes aren't in it. AT&T is curtailing research and in the process of moving us to a new location, so most of the servers have been down since last Thursday. It is hoped that the server environment should return to normal today.
User avatar (0000571)
erg (administrator)
2013-10-16 13:05

We finally have an updated build. Please try graphviz-2.35.20131016.msi or later. As usual, if the problem is still there, let us know.

- Issue History
Date Modified Username Field Change
2013-06-10 04:28 valexiev New Issue
2013-06-10 04:29 valexiev Tag Attached: html-label
2013-06-10 04:29 valexiev File Added: graph2.gv
2013-06-10 04:30 valexiev File Added: graph2.png
2013-06-10 04:30 valexiev File Added: graph2.svg
2013-06-10 04:58 valexiev File Added: html-label-bug.gv
2013-06-10 04:58 valexiev File Added: html-label-bug.png
2013-06-10 05:01 valexiev Note Added: 0000356
2013-10-10 16:45 erg Note Added: 0000564
2013-10-11 11:53 erg Assigned To => erg
2013-10-11 11:53 erg Status new => resolved
2013-10-11 11:53 erg Resolution open => fixed
2013-10-14 09:03 valexiev Note Added: 0000566
2013-10-14 09:03 valexiev Status resolved => feedback
2013-10-14 09:03 valexiev Resolution fixed => reopened
2013-10-14 11:04 erg Note Added: 0000567
2013-10-14 11:04 erg Status feedback => resolved
2013-10-14 11:04 erg Resolution reopened => fixed
2013-10-16 13:05 erg Note Added: 0000571


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker