Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002272graphvizDotpublic2013-03-22 13:402013-03-22 23:05
Reporterehoffman 
Assigned To 
PrioritynormalSeveritynormalReproducibilityhave not tried
StatusnewResolutionopen 
PlatformOSmac osx OS Version10.6.8
Summary0002272: unable to find ports across clusters given a certain edgeset
Descriptionunder 2.28 and 2.31, with the attached graph, dot -Tpdf reports

Warning: node n760541d, port f1 unrecognized
Warning: node n7e06676, port f1 unrecognized
Segmentation fault

if any edge is removed, the graph is drawn successfully

if I can cut down the test case, I'll update the problem report
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION
Attached Filesdot file icon t1.dot [^] (3,711 bytes) 2013-03-22 13:40

- Relationships

-  Notes
User avatar (0000325)
ehoffman (reporter)
2013-03-22 13:43

removing concentrate=true eliminates the report about not being able
to find the ports, but still results in a segv
User avatar (0000326)
ehoffman (reporter)
2013-03-22 23:05

this only occurs with the weight attribute set on the edges.

the segv happens in common_init_node ->late_double, presumably having
to do with setting up the node attributes

it doesn't seem possible for me to change it, but the priority for this issue
should be low

- Issue History
Date Modified Username Field Change
2013-03-22 13:40 ehoffman New Issue
2013-03-22 13:40 ehoffman File Added: t1.dot
2013-03-22 13:43 ehoffman Note Added: 0000325
2013-03-22 23:05 ehoffman Note Added: 0000326


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker