Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002211graphvizDotpublic2012-03-19 02:022013-09-12 21:59
ReporterKip 
Assigned Toerg 
PrioritynormalSeveritycrashReproducibilityalways
StatusresolvedResolutionfixed 
Platformamd64OSGNUOS VersionUbuntu Maverick
Summary0002211: dot segfaults
DescriptionUsing dot - graphviz version 2.28.0 (20110507.0427) on amd64 hardware, I am experience a segfault.
Steps To ReproduceRun the following command with the attached minimal:

$ dot -Tpdf minimal.dot -o minimal.pdf
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSIONdot - graphviz version 2.28.0 (20110507.0427)
Attached Filesdot file icon minimal.dot [^] (107 bytes) 2012-03-19 02:02

- Relationships

-  Notes
User avatar (0000205)
erg (administrator)
2012-03-19 10:11

The problem is that orthogonal edges do not currently support edge labels in dot. It should be possible to use xlabels instead. The code now produces a warning.
User avatar (0000206)
Kip (reporter)
2012-03-19 20:40

Hey erg. I didn't mean to re-open the issue, but I couldn't post a comment without it. I'm glad the bug has been found and a warning is issued instead, although it still does not solve my problem. Also, can xlabels be used on edges? I thought they only worked on nodes?
User avatar (0000207)
erg (administrator)
2012-03-20 08:49

We are at work trying to fix the basic problem. Also, note that the edge labels will be placed now with no change to the dot file. They just may overlap. As for xlabels, yes, they can be used with edges as well as nodes. In fact, part of the reason for doing them was that normal edge labels in dot can be too heavyweight, distorting the layout. Using xlabels allows the graph to be drawn naturally, with the edge labels added afterwards.
User avatar (0000208)
Kip (reporter)
2012-03-20 17:31

Hey erg. What do you mean that "edge labels will be placed now with no change to the dot file"? I could always get edge labels to work, but just not when they are on orthogonal edges. Or do you mean that you can use orthogonal edges with labels now?

I couldn't find much documentation on xlabels. Could you show me a sample of an edge using an xlabel? I've tried foo -> goo[xlabel="some label"] but that did not do anything.
User avatar (0000210)
erg (administrator)
2012-03-22 09:37

With the bug fixed, you should be able to run dot on your original file and get a reasonable drawing, even with splines=ortho.

As for xlabels, there is not much more to be said that what is in the documentation. For xlabels on edges in dot, the basic graph is laid out with nodes and ordinary edge labels. Then xlabels are placed in a manner to avoid overlapping nodes or other labels.

If you ran dot on the graph digraph { foo -> goo[xlabel="some label"]} and didn't see an edge label, then you are using a version of dot that predates xlabels. Ah, yes, I see you are using 2.28. The xlabel attribute wasn't added until 2.29.
User avatar (0000211)
Kip (reporter)
2012-03-22 18:52

Hey erg. The drawing already came out fine with splines=ortho, it's just the edge labels weren't working and would segfault dot if I enabled them. But I will try 2.29 and see if that helps now. Thanks a lot.
User avatar (0000522)
erg (administrator)
2013-09-12 21:59

The warning takes care of the seg fault. We still need to handle edge labels in dot with splines=ortho, though xlabels should provide a workaround.

- Issue History
Date Modified Username Field Change
2012-03-19 02:02 Kip New Issue
2012-03-19 02:02 Kip File Added: minimal.dot
2012-03-19 10:11 erg Note Added: 0000205
2012-03-19 10:11 erg Assigned To => erg
2012-03-19 10:11 erg Status new => closed
2012-03-19 10:11 erg Resolution open => fixed
2012-03-19 20:40 Kip Note Added: 0000206
2012-03-19 20:40 Kip Status closed => feedback
2012-03-19 20:40 Kip Resolution fixed => reopened
2012-03-20 08:49 erg Note Added: 0000207
2012-03-20 17:31 Kip Note Added: 0000208
2012-03-20 17:31 Kip Status feedback => assigned
2012-03-22 09:37 erg Note Added: 0000210
2012-03-22 18:52 Kip Note Added: 0000211
2013-09-12 21:59 erg Note Added: 0000522
2013-09-12 21:59 erg Status assigned => resolved
2013-09-12 21:59 erg Resolution reopened => fixed


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker