Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002180graphvizOtherpublic2012-01-02 04:052012-02-10 03:36
Reporteraniri 
Assigned Toerg 
PriorityurgentSeveritycrashReproducibilityalways
StatusassignedResolutionreopened 
Platformx86-32OSMS Windows XP Prof. SP2OS Versionbuild 5.1.2600
Summary0002180: Very small trivial test C++ project for Visual Studio 2005 (attached) crashes on gvFreeLibrary
DescriptionHere is the text of a program:
int _tmain(int argc, _TCHAR* argv[])
{
    Agraph_t *g;
    GVC_t *gvc;
    gvc = gvContext();
    g = agopen("g", AGRAPHSTRICT);

    Agraph_t* subGraph = agsubg(g, "cluster_star_0");
    //agsafeset(subGraph, "label", "net star", "");
    Agnode_t* cn = agnode(subGraph, "subgraph_node");

    gvLayout(gvc, g, "circo");
    gvRenderFilename(gvc, g, "gif", "out.gif");
    gvFreeLayout(gvc, g); //here it crashes
    
    agclose(subGraph);
    agclose(g);
    gvFreeContext(gvc);
}

Under debugger it raises access violation at gvFreeLayout. When executed from command line it prints to the console: "Error: agstrfree lost (some non-ascii characters)".

Output "exe" is written to the graphviz "bin" directory, that's why missing of some libraries or files is apparently not the case.
Steps To ReproduceJust compile and run this program.
Additional InformationHopefully, you resolve it.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.28
Attached Filesrar file icon graphviz_2_28.rar [^] (49,812 bytes) 2012-01-02 04:05
jpg file icon console_output.JPG [^] (41,094 bytes) 2012-02-10 03:27


jpg file icon graphviz_access_violation.JPG [^] (175,091 bytes) 2012-02-10 03:31


txt file icon callstack.txt [^] (450 bytes) 2012-02-10 03:34 [Show Content]
txt file icon loaded_modules.txt [^] (9,282 bytes) 2012-02-10 03:34 [Show Content]

- Relationships

-  Notes
User avatar (0000143)
erg (administrator)
2012-01-03 15:38

I believe the problem is fixed but I haven't been able to verify this on a Windows machine. The fixes will appear in tomorrow's (4 Jan 2012) packages.
Please let me know if you still have problems.
User avatar (0000158)
aniri (reporter)
2012-01-09 11:41
edited on: 2012-01-09 17:54

Hello,
the fixed binaries for windows aren't available yet as far as I can see. Are they expected in the near future? (or I should better try to build them myself)

User avatar (0000165)
erg (administrator)
2012-01-11 14:27

Normally they are built automatically every night, but the Windows build process is fragile. It appears to have broken again and the one person who knows how to fix it is out of the country and won't be back until 23 January.
User avatar (0000175)
aniri (reporter)
2012-01-30 13:50

In graphviz-2.29.20120126.0545 the bug was still there
User avatar (0000176)
aniri (reporter)
2012-01-30 14:28
edited on: 2012-01-30 14:35

the same crash with graphviz-2.29.20120130.0545

User avatar (0000178)
erg (administrator)
2012-01-31 17:03

I apologize for this. Our Windows guru has just returned and we went over the build process today. It appears that, for some time, the Windows development package was in fact just another copy of the stable release, which explains why you weren't seeing any improvement. We hope to have a true updated development package up shortly.
User avatar (0000187)
aniri (reporter)
2012-02-10 03:36
edited on: 2012-02-11 10:49

Unfortunately no changes for me with graphviz-2.29.20120208.0545.
Console output and other debug stuff is attached.


- Issue History
Date Modified Username Field Change
2012-01-02 04:05 aniri New Issue
2012-01-02 04:05 aniri File Added: graphviz_2_28.rar
2012-01-03 15:38 erg Note Added: 0000143
2012-01-03 15:38 erg Assigned To => erg
2012-01-03 15:38 erg Status new => resolved
2012-01-03 15:38 erg Resolution open => fixed
2012-01-09 11:41 aniri Note Added: 0000158
2012-01-09 11:41 aniri Status resolved => feedback
2012-01-09 11:41 aniri Resolution fixed => reopened
2012-01-09 11:43 aniri Note Edited: 0000158 View Revisions
2012-01-09 17:54 aniri Note Edited: 0000158 View Revisions
2012-01-11 14:27 erg Note Added: 0000165
2012-01-30 13:50 aniri Note Added: 0000175
2012-01-30 13:50 aniri Status feedback => assigned
2012-01-30 14:28 aniri Note Added: 0000176
2012-01-30 14:35 aniri Note Edited: 0000176 View Revisions
2012-01-31 17:03 erg Note Added: 0000178
2012-02-10 03:27 aniri File Added: console_output.JPG
2012-02-10 03:31 aniri File Added: graphviz_access_violation.JPG
2012-02-10 03:34 aniri File Added: callstack.txt
2012-02-10 03:34 aniri File Added: loaded_modules.txt
2012-02-10 03:36 aniri Note Added: 0000187
2012-02-11 10:49 aniri Note Edited: 0000187 View Revisions


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker