Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002121graphvizBuild/Installpublic2011-07-29 10:522011-07-29 12:36
Reporterroundsfunny 
Assigned To 
PrioritynormalSeverityimportantReproducibilityalways
StatusnewResolutionopen 
PlatformDell Power Edge 1650OSCentOSOS Version5.5
Summary0002121: Cannot update Graphviz - failed dependencies
DescriptionI use yum regularly to update the CentOS 5.5 instance I have, but on Tuesday ran yum and the graphviz update failed showing failed dependencies as follows:

--> Finished Dependency Resolution
graphviz-perl-2.26.3-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: graphviz = 2.26.3-1.el5 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
graphviz-perl-2.26.3-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgvc.so.5 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
graphviz-perl-2.26.3-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libcdt.so.4 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
graphviz-perl-2.26.3-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libgraph.so.4 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
Error: Missing Dependency: graphviz = 2.26.3-1.el5 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
Error: Missing Dependency: libgraph.so.4 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
Error: Missing Dependency: libcdt.so.4 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
Error: Missing Dependency: libgvc.so.5 is needed by package graphviz-perl-2.26.3-1.el5.i386 (installed)
Steps To Reproducerun yum update grapviz
Additional Informationall other packages are up-to-date
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT
VERSION2.26.3-1.el5
Attached Files

- Relationships

-  Notes
User avatar (0000040)
ellson (administrator)
2011-07-29 11:47

The problem is that there was no graphviz-perl extension built with the graphviz-2.28 release. You can either: "rpm -e graphviz-perl" before doing the yum update, or you can update to the nightly snapshot series which contain a fix for the graphviz-perl problem.

Sorry for the trouble.

[Side note to SN. Our el5 rpms are built on a fully updated centos-5.6 platform. ]

- Issue History
Date Modified Username Field Change
2011-07-29 10:52 roundsfunny New Issue
2011-07-29 11:47 ellson Note Added: 0000040
2011-07-29 12:36 ellson Note Added: 0000041
2011-07-29 12:48 ellson Note Deleted: 0000041


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker