Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002030graphvizTwopipublic2011-01-22 08:292011-11-08 12:17
ReporterPander 
Assigned Toerg 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOS*-*-OS Version
Summary0002030: Implement horizontal/vertical scaling (starting with twopi)
Description


Especially twopi can cause shapes and labels to overlap. Because it is not yet possible to (auto)rotate shapes and labels in twopi, I would like to propose the following additional solution. Als to simply have more control over teh resulting shape.



Please implement a setting on graph called
<CD>
  scale
</CD>
which is a double with default value
<CD>
  1.0
</CD>



For the moment only twopi will be influenced by it.



Implementing this will offers greater control of results, especially preventing shape and label overlapping.
Steps To Reproduce
digraph G {
  layout="twopi"
  scale="1.5"
  root -> {aaaaaaaaaaaaaaa baaaaaaaaaaaaaa caaaaaaaaaaaaaa daaaaaaaaaaaaaa eaaaaaaaaaaaaaa faaaaaaaaaaaaaa }
}
Additional Information
If one of the core developers is willing to mentor me, I would like to do the implementation and him step by step the patches so he can commit the changes in CVS.

The implementation only influence the x-coordinates. For scaling in the y-direction, use a value below 0.0 and increase ranksep. so scaling is possible in both directions.

However, scaling can be implemented for both x and y-direction via
<CD>
  scale="1.5:1.25"
  scale=":1.25"
  scale="1.5:"
  scale=":" == scale="1.0:1.0"
</CD>

Benefit is easier scaling in all directions in twopi, disadvantage is a little more complex implementation. But keeping scaling in mind for other renderers than twopi (which I cannot oversee) I will leave this decision up to the core developers.

Please response as soon as is convenient since now I have the time to work on this.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT 
<CD>
/graphviz2/lib/twopigen# diff circle.c.orig circle.c
313c313
< ND_pos(n)[0] = hyp * cos(THETA(n));
---
> > ND_pos(n)[0] = scale * hyp * cos(THETA(n));
</CD>
FORMER-ID2115
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTRequest
VERSION     2.27.0 (20110122.1251)
Attached Files

- Relationships

-  Notes
User avatar (0000107)
erg (administrator)
2011-11-08 12:16

Scaling has been added to twopi.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1
2011-11-08 12:16 erg Note Added: 0000107
2011-11-08 12:17 erg Assigned To gviz => erg
2011-11-08 12:17 erg Status acknowledged => closed
2011-11-08 12:17 erg Resolution no change required => fixed
2011-11-08 12:17 erg Description Updated View Revisions
2011-11-08 12:17 erg Steps to Reproduce Updated View Revisions
2011-11-08 12:17 erg Additional Information Updated View Revisions


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker