Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002012graphvizOutput Generationpublic2011-01-01 21:112011-04-28 04:03
ReporterYifan Hu 
Assigned Togviz 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOS*-*OS Version
Summary0002012: Missing image
Description



Using the attached 2 node graph with a \<A HREF="b2097.png"\>picture\</A\>
to be included in the html label,



<CD>
neato -v -Gsize=40,40! -Tpng:cairo -n2 junk1.gv > /tmp/1.png
</CD>



does not show the picture at all.



<CD>
neato -v -Gsize=40,40! -Tpng:gd -n2 junk1.gv > /tmp/1.png
</CD>






shows the picture, but is not useful as the font is bad, among other things.



Are you able to repeat this? Fixable?
Additional Information

[erg]

If the coordinates are changed to make the drawing a tad smaller, the image re-appears. I'm
guessing that cairo or our plugin must assume the scaled down image is too small and optimizes
it out.

[yifan]
I found a temp fix: just scale the image file to a small size (say 60x60 instead of 400x400). Seem that the compression down to small size is one reason why cairo failed.

TagsNo tags attached.
AUXILLARY-FILEShttp://www.graphviz.org/bugs/b2097.png [^]
DATE-FIXED
FIX-COMMENT
FORMER-ID2097
INPUT-FILEhttp://www.graphviz.org/bugs/b2097.gv [^]
OUTPUT-FILEhttp://www.graphviz.org/bugs/b2097a.png [^]
STATUS-COMMENT*
VERSION     2.27
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker