Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001963graphvizDotpublic2010-09-27 14:392011-04-28 04:03
Reporteruser36 
Assigned Toerg 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOS*-*-OS Version
Summary0001963: disconnected edges
Description
I've been trying to use GraphViz, specifically dot, to render a simple directed graph with 5 nodes in it. I want the nodes to be at the same rank with a series of straight edges connecting them (along the central axis). I've got a second set of dashed edges which mirror the first set of edges but bend down. The final set of edges I want connect each node (other than the source) with the source. The problem I'm getting is that dot doesn't seem to be drawing these back edges correctly. The edge D -> A doesn't connect correctly (the tail point is floating in the space between nodes C and D) and the edge E -> A seems to be entirely absent. Does anyone have any suggestions what I'm doing wrong, or what I can do to rectify these issues.
Additional Information

[ryan]
For the developers, here is a smaller test case:

<CD>
digraph G {

    rank=same {
        A -> B -> C -> D -> E
    }

    edge [ tailport = nw ]
    { B C D E } -> A

}
</CD>

The return edges from B and C look fine but the ones from D and E start at the wrong place.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID2044
INPUT-FILEhttp://www.graphviz.org/bugs/b2044.gv [^]
OUTPUT-FILE
STATUS-COMMENTFixed (5 Feb 2011)
VERSION     2.27
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker