Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001867graphvizDotpublic2010-04-27 06:142016-02-14 17:10
ReporterHenk van Voorthuijsen 
Assigned Togviz 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOS*-*-OS Version
Summary0001867: Database node shape
Description


At the moment, most available node shapes are simple geometric shapes.
When using GraphViz to describe system dependencies, I often find myself in need of the classic database cylinder.
Adding this shape would fit in nicely with shapes like component, folder, etc.
Additional Information
[henk] \<A HREF="b1937.jpg"\>Here\</A\> is an example.
TagsNo tags attached.
AUXILLARY-FILEShttp://www.graphviz.org/bugs/b1937.jpg [^]
DATE-FIXED
FIX-COMMENT
FORMER-ID1937
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT   Request
VERSION     
Attached Filespatch file icon 1867-cylinder-shape.patch (Attachment missing)

- Relationships

-  Notes
User avatar (0001004)
klutometis (reporter)
2015-12-30 18:18
edited on: 2015-12-30 18:21

We use Graphviz extensively at work for design-documents, and hardly a day goes by when I didn't wish that we had a database shape; Postscript à la http://rhodesmill.org/brandon/2007/a-database-symbol-for-graphviz/ [^] isn't an option, since we're going straight to PNG, and, due to the standardized nature of our document-production system, I can't patch a local Graphviz.

Would you consider applying the attached patch?

User avatar (0001023)
mtd (reporter)
2016-02-03 12:50

This would be a really nice shape to have in graphviz.
User avatar (0001036)
erg (administrator)
2016-02-14 17:10

As of 12 February 2016, there is now a cylinder shape for nodes.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1
2014-07-26 12:09 Peter Suter File Added: 1867-cylinder-shape.patch
2015-12-30 18:18 klutometis Note Added: 0001004
2015-12-30 18:19 klutometis Note Edited: 0001004 View Revisions
2015-12-30 18:20 klutometis Note Edited: 0001004 View Revisions
2015-12-30 18:20 klutometis Note Edited: 0001004 View Revisions
2015-12-30 18:21 klutometis Note Edited: 0001004 View Revisions
2016-02-03 12:50 mtd Note Added: 0001023
2016-02-14 17:10 erg Note Added: 0001036
2016-02-14 17:10 erg Status acknowledged => closed
2016-02-14 17:10 erg Resolution no change required => fixed
2016-02-14 17:10 erg Description Updated View Revisions
2016-02-14 17:10 erg Additional Information Updated View Revisions


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker