Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001826graphvizBuild/Installpublic2010-02-22 15:592011-04-28 04:03
Reportercharlie ruedi 
Assigned Togviz 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOSx86-Linux-rhel 5.4OS Version
Summary0001826: trouble installing graphviz-php.x86_64 0:2.16-1.el5
Description



Several of the 2.26 packages installed without issues. It appears some of the
packages are still 2.16 and are looking for older version of the other
packages.



I set up the repo file with the info I downloaded from your site.



<CD>
[[email protected] conf]# cat /etc/yum.repos.d/graphviz-rhel.repo
[graphviz-stable]
name=Graphviz - RHEL $releasever - $basearch
baseurl=http://www.graphviz.org/pub/graphviz/stable/redhat/el$releasever/$basearch/os/ [^]
enabled=1
gpgcheck=0



[graphviz-stable-source]
name=Graphviz - RHEL $releasever - Source
baseurl=http://www.graphviz.org/pub/graphviz/stable/SRPMS/ [^]
enabled=0
gpgcheck=0



[graphviz-stable-debuginfo]
name=Graphviz - RHEL - Debug
baseurl=http://www.graphviz.org/pub/graphviz/stable/redhat/el$releasever/$basearch/debug/ [^]
enabled=0
gpgcheck=0



[graphviz-snapshot]
name=Graphviz - RHEL $releasever - $basearch
baseurl=http://www.graphviz.org/pub/graphviz/development/redhat/el$releasever/$basearch/os/ [^]
enabled=0
gpgcheck=0



[graphviz-snapshot-source]
name=Graphviz - RHEL $releasever - Source
baseurl=http://www.graphviz.org/pub/graphviz/development/SRPMS/ [^]
enabled=0
gpgcheck=0



[graphviz-snapshot-debuginfo]
name=Graphviz - RHEL - Debug
baseurl=http://www.graphviz.org/pub/graphviz/development/redhat/el$releasever/$basearch/debug/ [^]
enabled=0
gpgcheck=0






[[email protected] conf]#






[[email protected] gts-snapshot-100130]# yum install graphvi*
Loaded plugins: rhnplugin, security
Setting up Install Process
Package graphviz-gd-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-guile-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-devel-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-doc-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-graphs-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-perl-2.26.3-1.el5.x86_64 already installed and latest version
Package graphviz-java-2.26.3-1.el5.x86_64 already installed and latest version
Resolving Dependencies
--> Running transaction check
---> Package graphviz-php.x86_64 0:2.16-1.el5 set to be updated
--> Processing Dependency: graphviz = 2.16-1.el5 for package: graphviz-php
--> Processing Dependency: libgvc.so.4()(64bit) for package: graphviz-php
---> Package graphviz-python.x86_64 0:2.26.3-1.el5 set to be updated
---> Package graphviz-ruby.x86_64 0:2.26.3-1.el5 set to be updated
--> Processing Dependency: /usr/bin/ruby for package: graphviz-ruby
--> Processing Dependency: ruby for package: graphviz-ruby
--> Processing Dependency: libruby.so.1.8()(64bit) for package: graphviz-ruby
---> Package graphviz-tcl.x86_64 0:2.26.3-1.el5 set to be updated
--> Running transaction check
---> Package graphviz-php.x86_64 0:2.16-1.el5 set to be updated
--> Processing Dependency: graphviz = 2.16-1.el5 for package: graphviz-php
--> Processing Dependency: libgvc.so.4()(64bit) for package: graphviz-php
---> Package ruby.x86_64 0:1.8.5-5.el5_4.8 set to be updated
---> Package ruby-libs.x86_64 0:1.8.5-5.el5_4.8 set to be updated
--> Finished Dependency Resolution
graphviz-php-2.16-1.el5.x86_64 from graphviz-stable has depsolving problems
  --> Missing Dependency: graphviz = 2.16-1.el5 is needed by package graphviz-php-2.16-1.el5.x86_64 (graphviz-stable)
graphviz-php-2.16-1.el5.x86_64 from graphviz-stable has depsolving problems
  --> Missing Dependency: libgvc.so.4()(64bit) is needed by package graphviz-php-2.16-1.el5.x86_64 (graphviz-stable)
Error: Missing Dependency: libgvc.so.4()(64bit) is needed by package graphviz-php-2.16-1.el5.x86_64 (graphviz-stable)
Error: Missing Dependency: graphviz = 2.16-1.el5 is needed by package graphviz-php-2.16-1.el5.x86_64 (graphviz-stable)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
[[email protected] gts-snapshot-100130]# rpm -qa |grep graph
graphviz-devel-2.26.3-1.el5
graphviz-guile-2.26.3-1.el5
graphviz-doc-2.26.3-1.el5
graphviz-graphs-2.26.3-1.el5
graphviz-java-2.26.3-1.el5
xorg-x11-drv-elographics-1.1.0-1.1
graphviz-gd-2.26.3-1.el5
graphviz-2.26.3-1.el5
graphviz-perl-2.26.3-1.el5
[[email protected] gts-snapshot-100130]#
</CD>
Additional Information

[ellson]
Try:

<CD>
    rpm -e graphviz-php
    yum install graphviz* -x graphviz-php
</CD>


We don't have a graphviz-php in the cuurrent .el5. builds. (Not sure why, since apparently the Redhat distro has one, but thats a separate issue.)


TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1891
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT*
VERSION     2.26/2.16
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker