Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001715graphvizBuild/Installpublic2009-09-16 19:472011-04-28 04:03
ReporterAyla Khan 
Assigned Toellson 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOther-Linux-Scientific Linux 5.2OS Version
Summary0001715: libtool looks for libexpat in the wrong location
Description



Building on x86_64 architecture.



Configured a test build using ./configure --prefix=/ccs/home/ayla/apps/graphviz --enable-python25=yes --enable-static=yes --enable-static --disable-shared --enable-shared=no --with-expat=yes.



Configure appears to work fine (I put an echo statement printing out the value of $EXPAT_LIBDIR, which gets set to /usr/lib64), but linking fails with the following error:



<CD>
libtool: link: gcc -g -O2 -Wno-unknown-pragmas -Wstrict-prototypes -Wpointer-arith -Wall -ffast-math -o dot_static dot_static-dot.o dot_static-dot_builtins.o /ccs/home/ayla/apps/fontconfig/lib/libfontconfig.so -L/ccs/home/ayla/apps/graphviz/lib ../../plugin/dot_layout/.libs/libgvplugin_dot_layout_C.a ../../plugin/neato_layout/.libs/libgvplugin_neato_layout_C.a ../../plugin/core/.libs/libgvplugin_core_C.a ../../lib/gvc/.libs/libgvc_C.a ../../lib/pathplan/.libs/libpathplan_C.a ../../lib/graph/.libs/libgraph_C.a ../../lib/xdot/.libs/libxdot_C.a ../../lib/cdt/.libs/libcdt_C.a /usr/lib/libexpat.so -lm ../../plugin/gd/.libs/libgvplugin_gd_C.a ../../lib/gd/.libs/libgvgd_C.a -lfreetype -ljpeg -lpng -lz ../../plugin/pango/.libs/libgvplugin_pango_C.a -L/lib64 -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -ldl
/usr/lib/libexpat.so: could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[3]: *** [dot_static] Error 1
make[3]: Leaving directory `/autofs/na1_home/ayla/devel/contour_tree/graphviz-2.25.20090916.0445/cmd/dot'
make[2]: *** [all-recursive] Error 1
</CD>
Additional Information

[ellson]
Check for /usr/lib/libexpat.la If its there it will cause this kind of problem. Solution: rm /usr/lib*/*.la
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1769
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed (17 Sep 2009)
VERSION     2.25.20090916.0445
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user695


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker