Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001701graphvizBuild/Installpublic2009-08-26 18:252011-04-28 04:03
ReporterClement Rey 
Assigned Toerg 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSx86-Unix-CentosOS Version
Summary0001701: install problem with using the option --with-sfdp
Description



I tried to install graphviz on my computer with the command :
confifgure --prefix=myrep --with-sfdp=yes
<CD>
I have the error message
./../plugin/neato_layout/.libs/libgvplugin_neato_layout.so: undefined reference to `remove_overlap'
collect2: ld returned 1 exit status
make[3]: *** [dot_builtins] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
</CD>



for both make and make install
And no executable are produced after.



If tried to install without the option --with-sfdp=yes it works but Ido not have the option sfdp(that normal) but i need it
Thank you



Clement REY
Additional Information

[erg] This bug was fixed just after the 2.24 release. It only occurs if
you request sfdp, but don't have a triangulation library installed, the
latter being necessary for sfdp to work. (One could argue that the sfdp
option should be turned off by configure if no triangle library is found.)

As it sounds like you wish to use sfdp, you should install the GTS library
and rerun configure and make.

TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1753
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed (27 Aug 2009)
VERSION     2.24
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker