Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001700graphvizDotpublic2009-08-25 14:462011-04-28 04:03
ReporterMichael Spiegel 
Assigned Togviz 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOS*-*-OS Version
Summary0001700: Loops from se to sw are incorrect
Description
A directed edge from vertex A to vertex A appears to be working with ports for all the cardinal directions except for "se" to "sw". In this case, a loop is drawn that wraps around the entire node. The dot input is a simple example that highlights the incorrect behavior in this case.
Steps To Reproduce

digraph Simple {
     x1 [shape=box,height=0.5,width=0.5];
     x2 [shape=box,height=0.5,width=0.5];
     x3 [shape=box,height=0.5,width=0.5];
     x4 [shape=box,height=0.5,width=0.5];
     x1 -> x1[dir=both,headport=sw,tailport=nw];
     x2 -> x2[dir=both,headport=ne,tailport=nw];
     x3 -> x3[dir=both,headport=sw,tailport=se];
     x3 -> x3[dir=both,headport=se,tailport=sw];
     x4 -> x4[dir=both,headport=ne,tailport=se];
}
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1752
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT*
VERSION     2.25.0
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker