Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001573graphvizBuild/Installpublic2009-03-25 22:442011-04-28 04:03
ReporterRodolfo Romero 
Assigned Toellson 
PrioritynormalSeveritycriticalReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSx86-Linux-Centos 5.2OS Version
Summary0001573: Error: Missing Dependency: ocaml is needed by package graphviz-ocaml
Description



I can't install graphviz packages using yum.



I issue the command
<CD>
$ yum install 'graphviz*'



It starts resolving all the dependencies and stops at some point showing the following error
Error: Missing Dependency: ocaml is needed by package graphviz-ocaml
</CD>



And this is the complete output.
<CD>
# yum install 'graphviz*'
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * addons: mirrors.portafixe.com
 * kbs-CentOS-Extras: centos.karan.org
 * kbs-CentOS-Misc: centos.karan.org
 * extras: mirrors.portafixe.com
 * graphviz-stable: www.graphviz.org
 * base: mirrors.portafixe.com
 * updates: mirrors.portafixe.com
kbs-CentOS-Misc 100% |=========================| 951 B 00:00
primary.xml.gz 100% |=========================| 157 B 00:00
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package graphviz-sharp.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: mono-core for package: graphviz-sharp
---> Package graphviz-ruby.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: /usr/bin/ruby for package: graphviz-ruby
--> Processing Dependency: libruby.so.1.8 for package: graphviz-ruby
--> Processing Dependency: ruby for package: graphviz-ruby
---> Package graphviz-java.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: java for package: graphviz-java
---> Package graphviz-php.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: php for package: graphviz-php
--> Processing Dependency: /usr/bin/php for package: graphviz-php
---> Package graphviz-tcl.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: tk for package: graphviz-tcl
--> Processing Dependency: libltdl.so.3 for package: graphviz-tcl
--> Processing Dependency: libtk8.4.so for package: graphviz-tcl
---> Package graphviz-ocaml.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: ocaml for package: graphviz-ocaml
---> Package graphviz.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-doc.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-guile.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: guile for package: graphviz-guile
---> Package graphviz-graphs.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-python.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-gd.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-devel.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-perl.i386 0:2.20.2-1.fc5 set to be updated
---> Package graphviz-cairo.i386 0:2.8-1.fc5 set to be updated
--> Running transaction check
---> Package ruby-libs.i386 0:1.8.5-5.el5_2.6 set to be updated
---> Package guile.i386 5:1.8.0-8.20060831cvs set to be updated
---> Package graphviz-ocaml.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: ocaml for package: graphviz-ocaml
---> Package tk.i386 0:8.4.13-5.el5_1.1 set to be updated
---> Package php-cli.i386 0:5.1.6-20.el5_2.1 set to be updated
--> Processing Dependency: php-common = 5.1.6-20.el5_2.1 for package: php-cli
---> Package libtool-ltdl.i386 0:1.5.22-6.1 set to be updated
---> Package mono-core.i386 0:1.2.4-2.el5.centos set to be updated
--> Processing Dependency: libgdiplus for package: mono-core
---> Package ruby.i386 0:1.8.5-5.el5_2.6 set to be updated
---> Package java-1.4.2-gcj-compat.i386 0:1.4.2.0-40jpp.115 set to be updated
filelists.xml.gz 100% |=========================| 150 B 00:00
--> Processing Dependency: gjdoc for package: java-1.4.2-gcj-compat
--> Processing Dependency: jpackage-utils >= 1.6.6-1jpp_1rh for package: java-1.4.2-gcj-compat
--> Processing Dependency: jpackage-utils >= 1.6.6-1jpp_1rh for package: java-1.4.2-gcj-compat
--> Processing Dependency: /usr/bin/rebuild-security-providers for package: java-1.4.2-gcj-compat
--> Processing Dependency: /usr/bin/rebuild-security-providers for package: java-1.4.2-gcj-compat
---> Package php.i386 0:5.1.6-20.el5_2.1 set to be updated
--> Running transaction check
---> Package libgdiplus.i386 0:1.2.5-1.el5.centos set to be updated
--> Processing Dependency: libgif.so.4 for package: libgdiplus
---> Package graphviz-ocaml.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: ocaml for package: graphviz-ocaml
---> Package php-common.i386 0:5.1.6-20.el5_2.1 set to be updated
---> Package gjdoc.i386 0:0.7.7-12.el5 set to be updated
--> Processing Dependency: antlr for package: gjdoc
---> Package jpackage-utils.noarch 0:1.7.3-1jpp.2.el5 set to be updated
--> Running transaction check
---> Package graphviz-ocaml.i386 0:2.20.2-1.fc5 set to be updated
--> Processing Dependency: ocaml for package: graphviz-ocaml
---> Package antlr.i386 0:2.7.6-4jpp.2 set to be updated
---> Package giflib.i386 0:4.1.3-7.1.el5.1 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: ocaml is needed by package graphviz-ocaml
</CD>
Additional Information

[ellson] The problem is that you are trying to install fedora-5 rpms on a centos-5 system.

Please use the rpms for rhel5/centos5 (with the extension .el5.rpm). They
don't include graphviz-ocaml for exactly the reason you identified.

Also, for rhel5/centos5, there are rpms for the latest stable graphviz-2.22.2.

[rodolfo]
So that means that I shouldn't do the install using yum? I tried to do it through rpm but there are too many dependencies and yum is suppose to solve that for you. Any advice will be appreciated.

[ellson]
um should be fine, but you need the right /etc/yum.repos.d/graphviz-rhel.repo

Grab it from:
    http://graphviz.org/graphviz-rhel.repo [^]

If you currently have /etc/yum.repos.d/graphviz-fedora.repo, you should remove it.

[rodolfo]
Sorry to bother you again. Now I'm getting these errors

 

Error: Missing Dependency: libgvc.so.4 is needed by package graphviz-php

Error: Missing Dependency: graphviz = 2.16-1.el5 is needed by package graphviz-php

 
[ellson]
Try:
<CD>
    rpm -e graphviz-php
    yup update graphviz
</CD>
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1614
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENTFixed
VERSION     2.22.2.1
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user695


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker