Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001477graphvizGraph Librariespublic2008-11-06 15:002015-06-13 22:22
Reporteruser442 
Assigned Togviz 
PrioritynormalSeverityminorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOS*-*-OS Version
Summary0001477: Library loses attributes
Description



There is a conflict between the default conventions of the library and
the layout programs. The layout programs assume node labels = "\N" unless
otherwise specified. The library assumes label = "". So, if the given
input graph is processed by the library, one ends up with



digraph {
        a;
        b;
}



which involves a loss of information when sent to dot.
Steps To Reproduce

digraph {
  a [label=""]
  b
}
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT
FORMER-ID1514
INPUT-FILE
OUTPUT-FILE
STATUS-COMMENT*
VERSION     2.21
Attached Filesdiff file icon _graphviz-empty-node-label.diff (Attachment missing)

- Relationships

-  Notes
User avatar (0000941)
dmaggot (reporter)
2015-05-25 11:15

The attached patch detects if a node label is set to the empty string and marks it to be printed. It fixes my case where I create graphs with the cgraph library and set the node label to "", but I don't know if this is exactly the case originally reported.
User avatar (0000949)
dmaggot (reporter)
2015-06-13 22:22

ping?

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1
2015-05-25 11:13 dmaggot File Added: _graphviz-empty-node-label.diff
2015-05-25 11:15 dmaggot Note Added: 0000941
2015-06-13 22:22 dmaggot Note Added: 0000949


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker