Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001394graphvizDotpublic2008-08-27 00:002011-04-28 04:03
ReporterStas Fomin 
Assigned Togviz 
PrioritynormalSeveritymajorReproducibilityalways
StatusacknowledgedResolutionopen 
PlatformOS*-*-*OS Version
Summary0001394: "rank=same" + "shape=Mrecord" + UTF8 = Abort (dot crashes)
Description






Dot (2.18 and 2.20, on Windows and Linux) crushes on graphs with subclasters and shape records.



On Windows it looks like:
<CD>
-----------------------------------------------------------------
D:\temp\Bug41324>dot -V
dot - Graphviz version 2.18 (Fri Mar 28 18:30:32 GMT 2008)



D:\temp\Bug41324>dot -Tsvg -o d.svg bred.dot
Warning: af was already in a rankset, ignored in cluster G
Warning: at was already in a rankset, ignored in cluster G
Warning: uaf was already in a rankset, ignored in cluster G
Warning: uat was already in a rankset, ignored in cluster G



This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.
-----------------------------------------------------------------
</CD>



On Linux it looks like:
<CD>
-----------------------------------------------------------------
goblin:~/Bug41324# dot -V
dot - Graphviz version 2.20.0 (Tue Aug 5 15:37:10 UTC 2008)



goblin:~/Bug41324# dot -Tpng -o d.svg bred.dot
Warning: af was already in a rankset, ignored in cluster G
Warning: at was already in a rankset, ignored in cluster G
Warning: uaf was already in a rankset, ignored in cluster G
Warning: uat was already in a rankset, ignored in cluster G
Aborted
-----------------------------------------------------------------
</CD>



I try to provide minimal file sample
(removing any couple of characters removes dot crush).



All such «bad» graphs successfully processed by dot v2.8



This bug looks like Bug 1372 which is unfortunately still open.






Sincerely, Stas Fomin



P.S. Before I try to submit this bug by webform interface,
but after submitting I receive blank page so
I am not sure, that my bug report is submitted.
Additional Information

[erg] The bug doesn't involve UTF-8, but something with records,
edge labels and the flat edge. \<A HREF="b1430a.dot"\>Here\</A\> is
a reduced graph causing the problem.
TagsNo tags attached.
AUXILLARY-FILEShttp://www.graphviz.org/bugs/b1430a.dot [^]
DATE-FIXED
FIX-COMMENT
FORMER-ID1430
INPUT-FILEhttp://www.graphviz.org/bugs/b1430.dot [^]
OUTPUT-FILE
STATUS-COMMENT*
VERSION   2.18, 2.20
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => user1


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker