Graphviz Issue Tracker
Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001196graphvizDotpublic2007-11-11 05:432011-04-28 04:03
ReporterDarren Davison 
Assigned Toerg 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSx86-Linux-Ubuntu 7.10OS Version
Summary0001196: png image in HTML-like label out of position in SVG output
Description



Converting the supplied .dot file to png works fine and the included
png icons in the IMG label tags are correctly displayed. When the
output type is SVG however, the included png icons appear not to be
displayed at all, although they are referenced in the svg output.



steps to reproduce:



$ dot -Tsvg -otest.svg test.dot
Steps To Reproduce

digraph G {
    graph [
        ratio="auto"
    ];
    node [
        fontname="sans",
        fontsize="9"
    ];
    edge [ ];

    "node" [
        label=<<table><tr><td>node</td>
            <td><img src="session.png"/></td></tr></table>>
    ];
}
Additional Information

[erg] I believe this is now working correctly.
TagsNo tags attached.
AUXILLARY-FILES
DATE-FIXED
FIX-COMMENT 
In the output, the value of y='17' for the session.png image seems to
be wrong. Changing this manually to -29 in this example causes the
session.png to render in the correct place. The formula appears to
be the value of

./ellipse@cy - (image@height /
FORMER-ID1227
INPUT-FILE
OUTPUT-FILEhttp://www.graphviz.org/bugs/b1227.svg [^]
STATUS-COMMENTFixed
VERSION     dot - Graphviz version 2.12 (Tue Sep 4 16:56:48 UTC 2007)
Attached Files

- Relationships

-  Notes
There are no notes attached to this issue.

- Issue History
Date Modified Username Field Change
2011-04-28 04:03 user1 New Issue
2011-04-28 04:03 user1 Assigned To => erg


MantisBT 1.2.5[^]
Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker