Graphviz Issue Tracker - graphviz
View Issue Details
0002604graphvizBuild/Installpublic2016-10-14 09:552016-10-14 09:59
Jaroslav Skarvada 
 
normalminoralways
newopen 
graphviz-2.38.0
0002604: graphviz-2.38.0 fails to build with ghostscript-9.18+
gvloadimage_gs.c: In function 'gs_error':
gvloadimage_gs.c:75:16: error: 'e_VMerror' undeclared (first use in this function)
     if (err >= e_VMerror)
                ^~~~~~~~~
gvloadimage_gs.c:75:16: note: each undeclared identifier is reported only once for each function it appears in
gvloadimage_gs.c:77:21: error: 'e_unregistered' undeclared (first use in this function)
     else if (err >= e_unregistered)
                     ^~~~~~~~~~~~~~
gvloadimage_gs.c:79:21: error: 'e_invalidid' undeclared (first use in this function)
     else if (err >= e_invalidid)
                     ^~~~~~~~~~~

Build with ghostscript-9.18+ (I have tried with 9.20)
Proposed fix added.
No tags attached.
patch graphviz-2.38.0-gs-9.18-fix.patch (653) 2016-10-14 09:55
http://www.graphviz.org/mantisbt/file_download.php?file_id=517&type=bug
Issue History
2016-10-14 09:55Jaroslav SkarvadaNew Issue
2016-10-14 09:55Jaroslav SkarvadaFile Added: graphviz-2.38.0-gs-9.18-fix.patch
2016-10-14 09:59Jaroslav SkarvadaNote Added: 0001060

Notes
(0001060)
Jaroslav Skarvada   
2016-10-14 09:59   
It will also require ifdefs to support older ghostscripts as well.