Graphviz Issue Tracker - graphviz
View Issue Details
0002600graphvizDotpublic2016-06-09 17:032016-06-09 17:03
graphVizKid 
 
highimportantalways
newopen 
MacBook Air OS X El Capitan 10.11.5
2.39.20160526.1729
0002600: dot error "Error: lost n n edge": edge missing for simple graphs with records
With the spline setting of "curved" dot reports the error

Error: lost n n edge

for a simple graph containing nodes defined using html-like records.
Here is a simple example:

digraph G {
node [shape=plaintext]
splines = curved

n [label=<
  <TABLE BORDER="0" CELLBORDER="1" CELLSPACING="0">
  <TR><TD border="0"> </TD>
    <TD PORT="2">z</TD>
    <TD border="0"> </TD>
  </TR>
  <TR> <TD ROWSPAN="4" COLSPAN="3">
A
</TD> </TR>
  <TR> <TD border="0"> </TD> </TR>
  <TR><TD PORT="1">y</TD></TR>
  <TR> <TD border="0"> </TD></TR>
  <TR><TD border="0"> </TD>
    <TD PORT="0">x</TD>
  <TD border="0"> </TD>
  </TR>
  </TABLE>>];

n:1 -> n:2 ;
n:0 -> n:1 ;
}
I am using graphviz version 2.39.20160526.1729 (20160526.1729)

The error occurs when I try to generate an svg file (or ps or png), eg:

dot -Tsvg dot-curved.gv -o dot-curved.gv.svg

If you reorder the edges, you still get an error, but the other edge is displayed. If you just have one edge, it works fine.

If you use a different value for splines, the error goes away.
No tags attached.
? dot-curved.gv (498) 2016-06-09 17:03
http://www.graphviz.org/mantisbt/file_download.php?file_id=510&type=bug
Issue History
2016-06-09 17:03graphVizKidNew Issue
2016-06-09 17:03graphVizKidFile Added: dot-curved.gv

There are no notes attached to this issue.