Graphviz Issue Tracker - graphviz
View Issue Details
0002397graphvizOutput Generationpublic2013-11-28 09:192013-12-05 11:42
vkh 
ellson 
normalminoralways
resolvedfixed 
Ubuntu precise
2.26.3
0002397: regression since 2.20.2 - extra padding forced around image within node
At some point after 2.20.2, extra padding is added around images in a node. I'm attaching an example that shows the extra padding.
1. d/l and store the attached padding.gv in current directory
2. d/l and store the attached face.png in /tmp
3. execute `dot -Tpdf -o padding.pdf padding.gv'
4. compare with the attached nopadding-2.20.2.pdf (expected output -- obtained with 2.20.2) and with the attached extrapadding-2.26.3.pdf (broken output -- obtained with 2.26.3)
This is tracked downstream at
http://www.gramps-project.org/bugs/view.php?id=6999 [^]
html-label
? padding.gv (620) 2013-11-28 09:19
http://www.graphviz.org/mantisbt/file_download.php?file_id=316&type=bug
pdf nopadding-2.20.2.pdf (25,573) 2013-11-28 09:20
http://www.graphviz.org/mantisbt/file_download.php?file_id=317&type=bug
pdf extrapadding-2.26.3.pdf (25,586) 2013-11-28 09:20
http://www.graphviz.org/mantisbt/file_download.php?file_id=318&type=bug
png face.png (17,195) 2013-11-28 09:21
http://www.graphviz.org/mantisbt/file_download.php?file_id=319&type=bug
png
Issue History
2013-11-28 09:19vkhNew Issue
2013-11-28 09:19vkhFile Added: padding.gv
2013-11-28 09:20vkhFile Added: nopadding-2.20.2.pdf
2013-11-28 09:20vkhFile Added: extrapadding-2.26.3.pdf
2013-11-28 09:21vkhFile Added: face.png
2013-11-28 09:24vkhTag Attached: html-label
2013-11-28 15:44ellsonNote Added: 0000609
2013-11-28 16:23vkhNote Added: 0000610
2013-11-28 17:00pducrotNote Added: 0000611
2013-11-28 20:13vkhNote Added: 0000612
2013-11-28 20:18vkhNote Added: 0000613
2013-12-05 11:42ergAssigned To => ellson
2013-12-05 11:42ergStatusnew => resolved
2013-12-05 11:42ergResolutionopen => fixed

Notes
(0000609)
ellson   
2013-11-28 15:44   
This bug has been recently fixed.

The bug is still present in graphviz.2.34.0 (fedora-20) but is fixed in the current snapshots (2.35....) from graphviz.org.
(0000610)
vkh   
2013-11-28 16:23   
Thank you very much for the news and for the fix! I hope ubuntu 14.04 picks it up, too.

Thanks for the great tool,
V.
(0000611)
pducrot   
2013-11-28 17:00   
Hi,

I recently upgraded from 2.28 to 2.34, and that bug appeared (MacOSX 10.8) with no changes in the dot file I use to generate the graph.

Pierre
(0000612)
vkh   
2013-11-28 20:13   
Thanks for the info -- it means that 2.28 was still good. Well, the next stable release (2.36) is what is going to help us according to 0002397:0000609...
(0000613)
vkh   
2013-11-28 20:18   
Hold on a second --- it actually means this was broken after 2.20 --- because I see it in 2.26 --- then fixed in 2.28 because it worked for you there, then broken again!