unable to use prism

Hi All,
I'm trying to use graph viz to generate a relationship map of pairs of data. My problem is I have thousands of nodes and the default overlap settings are causing substantial data to be covered by the other nodes. I'm trying to use overlap=prism but I keep getting an error that prism is not supported.
I read on here that I needed to install the GTS libraries before installing graphviz so I removed graphviz and attempted to install gts. My problem still existed.
I've tried building from source on Debian and Ubuntu 14.04. I even tried building GTS from source but when I ./configure graphviz, gts isn't detected.
I'm sure I'm missing something simple here. Any help is greatly appreciated.

You can look in config.log to

You can look in config.log to find out why gts is not being found.

The configure script assumes it can find gts using the pkg-config command. In particular, it needs to find the gts.pc file, which is usually stored in the pkgconfig subdirectory of a library directory. You can usually fix this by using the PKG_CONFIG_PATH environment variable to specify the path. Or you can use the GTS_CFLAGS and GTS_LIBS environment variables to tell configure where to find the GTS include file and library, respectively.

Alternatively, you can grab triangle.c and triangle.c from, e.g., http://www.cs.cmu.edu/~quake/triangle.html, put them into lib/sfdpgen and re-run configure.

If you want more details, let me know.

Triangle error

Hey,

I have the same error but a bit of a linux noob, i'm using centos, could you give me detailed instructions on how to install grahpviz with gts?

Kr,

Borrie

Perfect! This solved it.

Perfect!

This solved it. Thanks so much :)

Recent comments