Trouble with neato in Graphviz GUI

I am new to Graphviz. I am running the GUI version of the program on my mac laptop.

I am trying to draw a complete graph in NEATO, and I want to be able to define the distance between nodes. I am therefore using the mds model. My small "test block" is printed below this message.

Problem is, the distances in the final graph are all equal, despite the "len" variable and the mds model. Possibly the GUI is trying to draw this as a DOT graph instead of a NEATO? How do I tell the GUI program I want a NEATO format?

Or am I way off?

Any help is much appreciated.

graph G {
model = mds;
splines = false;
n0 -- n1 [len=5, style = bold];
n1 -- n2 [len=1];
n2 -- n3 [len=3];
n2--ns [len=2];
ns--nk -- mk;
}

Trouble with neato in Graphviz GUI

On 3/30/11 8:23 PM, [email protected] wrote:
> I am trying to draw a complete graph in NEATO, and I want to be able
> to define the distance between nodes. I am therefore using the mds
> model. My small "test block" is printed below this message.
>
> Problem is, the distances in the final graph are all equal, despite
> the "len" variable and the mds model. Possibly the GUI is trying to
> draw this as a DOT graph instead of a NEATO? How do I tell the GUI
> program I want a NEATO format?
>
> Or am I way off?
>
> Any help is much appreciated.
>
>
> graph G {
> model = mds;
> splines = false;
> n0 -- n1 [len=5, style = bold];
> n1 -- n2 [len=1];
> n2 -- n3 [len=3];
> n2--ns [len=2];
> ns--nk -- mk;
> }
You are right. By default, graphviz.app runs the dot layout. To get a
different layout, set the layout attribute in
the graph

layout = neato

Note that, unless you work with a complete graph, model=mds isn't going
to get you anything
over model=major or even model=KK.

Emden

_______________________________________________
[email protected]
https://mailman.research.att.com/mailman/listinfo/graphviz-interest

Trouble with neato in Graphviz GUI

I am new to Graphviz. I am running the GUI version of the program on my mac
laptop.

I am trying to draw a complete graph in NEATO, and I want to be able to
define the distance between nodes. I am therefore using the mds model. My
small "test block" is printed below this message.

Problem is, the distances in the final graph are all equal, despite the "len"
variable and the mds model. Possibly the GUI is trying to draw this as a DOT
graph instead of a NEATO? How do I tell the GUI program I want a NEATO
format?

Or am I way off?

Any help is much appreciated.

graph G {
model = mds;
splines = false;

Recent comments