Problem: Installing on rhel6 - Missing dependency - libz.so when it is already installed (lbz.so.1.2.3)

Hi:
Before hand, thanks for your help

Problem:
I'm installing on rhel6 (x86_64) the file graphviz-2.34.0-1.el6.x86_64.rpm

It report the following problem at the end of the messages:

--> Finished Dependency Resolution
Error: Package: graphviz-2.34.0-1.el6.x86_64 (graphviz-stable)
Requires: libz.so.1(ZLIB_1.2.0)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

When I found that libz.so it's already installed:
[[email protected] lib64]$ ll libz*
lrwxrwxrwx. 1 root root 25 nov 29 2011 libz.so -> ../../lib64/libz.so.1.2.3
[[email protected] lib64]$ pwd
/usr/lib64

What should I do?

Regards,
Jose

re: Problem installing on rhel6

Not sure.  Can't recreate this problem locally

You could try: yum reinstall zlib zlib-devel

I see you listed the softlink:  "libz.so -> ../../lib64/libz.so.1.2.3"  from the zlib-dev package, 

but are "/lib64/libz.so.1.2.3"  and the link "/lib64/libz.so.1 -> /lib64/libz.so.1.2.3" also there?

These are from the zlib package:

     $ rpm -qf /lib64/libz.so.1
     zlib-1.2.3-29.el6.x86_64

 

Problem: Installing on rhel6 - libz files already

Hi ellson:

I found these files:

[[email protected] monpos]$ cd /lib64
You have new mail in /var/spool/mail/oracle
[[email protected] lib64]$ ll libz*
lrwxrwxrwx. 1 root root    13 sep 11 17:12 libz.so.1 -> libz.so.1.2.3
-rwxr-xr-x. 1 root root 88240 jun  1  2010 libz.so.1.2.3
[[email protected] lib64]$ cd /usr/lib64
[[email protected] lib64]$ ll libz*
lrwxrwxrwx. 1 root root 25 sep 11 17:12 libz.so -> ../../lib64/libz.so.1.2.3
[[email protected] lib64]$ 

I even reinstalled zlib and zlib-devel but the problem persists

Thanks for your help and ideas

Best regards,
Jose

 

The files are there at /lib64

Hi:

The files are at /lib64/ directory

[[email protected] lib64]# ll /lib64/libz*
lrwxrwxrwx. 1 root root    13 sep 11 17:12 /lib64/libz.so.1 -> libz.so.1.2.3
-rwxr-xr-x. 1 root root 85864 jun  1  2010 /lib64/libz.so.1.2.3
[[email protected] lib64]# 

I even reinstalled zlib zlib-devel using the command:

yum install zlib zlib-devel

and the error persist after trying installing:

yum install omd-1,00

The final lines of yum install are:

--> Finished Dependency Resolution
Error: Package: graphviz-2.34.0-1.el6.x86_64 (graphviz-stable)
           Requires: libz.so.1(ZLIB_1.2.0)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Regards,
Jose

 

 

I'm sorry but I still can't

I'm sorry but I still can't recreate this problem here:

 

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 6.4 (Santiago)
# yum reinstall zlib graphviz

...

Installed:
  graphviz.x86_64 0:2.34.0-1.el6           zlib.x86_64 0:1.2.3-29.el6          

Complete!

# ls -l /lib64/libz*
lrwxrwxrwx. 1 root root    13 Sep 12 12:15 /lib64/libz.so.1 -> libz.so.1.2.3
-rwxr-xr-x. 1 root root 88600 Oct  3  2012 /lib64/libz.so.1.2.3

 

 

I note that your /lib64/libz.so.1.2.3 is a different size than mine.

Also, you did an "install" rather than a "reinstall"

 

 

I can recreate the problem

Hi all

I have the same problem with RHEL 6U3 x64. Upgrade to 6u4 solve the problem ?
 

Re: Upgrade to 6u4 solve the problem ?

I don't know, but I always build our binary packages on fully updated systems, so its quite possible.

Eureka!

Hi,

After we update ours systems to 6u4 their packages works fine.

Thanks

Any workaround for RHEL 6.3?

Hi,

Has anybody found a way to install the latest version of graphviz on RHEL 6.3?

Unfortunately upgrading to RHEL 6.4 is not an option in my case.

Best regards

Michel

redhat 6.3 issue

Hi,

I am facing the exact same issue and unfortunately upgrading RHEL is not an option.

Did anybody figure out a way to install the latest version of graphviz on RHEL 6.3?

Thanks

Michel

Fixed the issue. It was with

Fixed the issue.

It was with the version of Zlib.

RHEL 6.3 ships with zlib 1.2.3-27 and somehow graphviz 2.38 doesn't like it. When I upgraded zlib to 1.2.3-29 it worked.

Regards

Michel

how to Upgrade zlib

How did u upgrade zlib to 1.2.3-29? Its not available in my repo. i am using a RHEL 6.3

Recent comments