libgv-php5

I am trying to use NodeViz, which requires libgv-php5. I am running Ubuntu Precise, 64 bit. The apt-get version of libgv-php5 (2.26) uses the PHP dl() command which has been removed from various SAPIs. I was trying to install the 2.38 version, which is listed as the most recent stable release on the website, only as far as I can tell, those packages don't actually include the gv.php file. (They include the man page for the file, but not the file itself.) Am I missing something?

/usr/share/php/gv.php

Please try our latest build.  You should now find  /usr/share/php/gv.php in it.

Thanks for the report.

/usr/share/php/gv.php still contains deprecated dl() call

This was on graphviz version 2.39.20140623.0445 (20140623.0445).

For reference: http://stackoverflow.com/questions/16163525/call-to-undefined-function-dl

Re:/usr/share/php/gv.php still contains deprecated dl() call

This call is from SWIG-generated code, so if it is wrong it is a bug in SWIG.

Works for me on Fedora-20 with swig-2.0.11-1 and php-5.5.13-3

What versions do you have?

Re:/usr/share/php/gv.php still contains deprecated dl() call

My ubuntu build hosts were in need of updates, so possibly that was the issue.   Please try tonight's build (should be available after 05:00 GMT)

Recent comments