Graphviz stable on CentOS 7 64bits

I am struggling to install graphviz on a recent CentOS 7 64 bit version
I have added the provided repo file as instructed on the http://graphviz.org/Download_linux_rhel.php page , but the yum command spits a lot of error messages about version issues on dependencies.
Has anyone succeeded in installing graphviz on CentOS 7 ?

Thank you for you help

============= TRACE BELOW =====================

$ sudo yum install 'graphviz*'
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: centos.mirror.fr.planethoster.net
* epel: fr2.rpmfind.net
* extras: centos.mirror.fr.planethoster.net
* updates: centos.weezel.co.uk
Package graphviz-tcl is obsoleted by graphviz-lang-tcl, trying to install graphviz-lang-tcl-2.38.0-1.el7.x86_64 instead
Package graphviz-ruby is obsoleted by graphviz-lang-ruby, trying to install graphviz-lang-ruby-2.38.0-1.el7.x86_64 instead
Package graphviz-php is obsoleted by graphviz-lang-php, trying to install graphviz-lang-php-2.38.0-1.el7.x86_64 instead
Package graphviz-java is obsoleted by graphviz-lang-java, trying to install graphviz-lang-java-2.38.0-1.el7.x86_64 instead
Package graphviz-guile is obsoleted by graphviz-lang-guile, trying to install graphviz-lang-guile-2.38.0-1.el7.x86_64 instead
Package graphviz-perl is obsoleted by graphviz-lang-perl, trying to install graphviz-lang-perl-2.38.0-1.el7.x86_64 instead
Package graphviz-lua is obsoleted by graphviz-lang-lua, trying to install graphviz-lang-lua-2.38.0-1.el7.x86_64 instead
Package graphviz-python is obsoleted by graphviz-lang-python, trying to install graphviz-lang-python-2.38.0-1.el7.x86_64 instead
Package graphviz-ocaml is obsoleted by graphviz-lang-ocaml, trying to install graphviz-lang-ocaml-2.38.0-1.el7.x86_64 instead
Resolving Dependencies
--> Running transaction check
---> Package graphviz.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: libgts-0.7.so.5()(64bit) for package: graphviz-2.38.0-1.el7.x86_64
---> Package graphviz-devel.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-doc.noarch 0:2.38.0-1.el7 will be installed
---> Package graphviz-gd.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-graphs.noarch 0:2.38.0-1.el7 will be installed
---> Package graphviz-lang-guile.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: libguile-2.0.so.22(GUILE_2.0)(64bit) for package: graphviz-lang-guile-2.38.0-1.el7.x86_64
--> Processing Dependency: guile for package: graphviz-lang-guile-2.38.0-1.el7.x86_64
--> Processing Dependency: libgc.so.1()(64bit) for package: graphviz-lang-guile-2.38.0-1.el7.x86_64
--> Processing Dependency: libguile-2.0.so.22()(64bit) for package: graphviz-lang-guile-2.38.0-1.el7.x86_64
---> Package graphviz-lang-java.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-lang-lua.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-lang-ocaml.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(runtime) = 4.00.1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
---> Package graphviz-lang-perl.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-lang-php.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: /usr/bin/php for package: graphviz-lang-php-2.38.0-1.el7.x86_64
---> Package graphviz-lang-python.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-lang-ruby.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: /usr/bin/ruby for package: graphviz-lang-ruby-2.38.0-1.el7.x86_64
--> Processing Dependency: ruby for package: graphviz-lang-ruby-2.38.0-1.el7.x86_64
--> Processing Dependency: libruby.so.2.0()(64bit) for package: graphviz-lang-ruby-2.38.0-1.el7.x86_64
---> Package graphviz-lang-tcl.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: tcl >= 8.3 for package: graphviz-lang-tcl-2.38.0-1.el7.x86_64
--> Processing Dependency: tk for package: graphviz-lang-tcl-2.38.0-1.el7.x86_64
--> Processing Dependency: /usr/bin/tclsh for package: graphviz-lang-tcl-2.38.0-1.el7.x86_64
--> Processing Dependency: libtk8.5.so()(64bit) for package: graphviz-lang-tcl-2.38.0-1.el7.x86_64
---> Package graphviz-libs.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-plugins-core.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-plugins-gd.x86_64 0:2.38.0-1.el7 will be installed
---> Package graphviz-plugins-x.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: libpoppler-glib.so.8()(64bit) for package: graphviz-plugins-x-2.38.0-1.el7.x86_64
---> Package graphviz-qt.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: libQtGui.so.4()(64bit) for package: graphviz-qt-2.38.0-1.el7.x86_64
--> Processing Dependency: libQtCore.so.4()(64bit) for package: graphviz-qt-2.38.0-1.el7.x86_64
---> Package graphviz-x.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: libglut.so.3()(64bit) for package: graphviz-x-2.38.0-1.el7.x86_64
--> Processing Dependency: libXaw.so.7()(64bit) for package: graphviz-x-2.38.0-1.el7.x86_64
--> Processing Dependency: libgdkglext-x11-1.0.so.0()(64bit) for package: graphviz-x-2.38.0-1.el7.x86_64
--> Processing Dependency: libgtkglext-x11-1.0.so.0()(64bit) for package: graphviz-x-2.38.0-1.el7.x86_64
--> Running transaction check
---> Package compat-poppler022-glib.x86_64 0:0.22.5-4.el7 will be installed
--> Processing Dependency: compat-poppler022(x86-64) = 0.22.5-4.el7 for package: compat-poppler022-glib-0.22.5-4.el7.x86_64
--> Processing Dependency: libpoppler.so.37()(64bit) for package: compat-poppler022-glib-0.22.5-4.el7.x86_64
---> Package freeglut.x86_64 0:2.8.1-3.el7 will be installed
---> Package gc.x86_64 0:7.2d-7.el7 will be installed
---> Package graphviz-lang-ocaml.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(runtime) = 4.00.1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
---> Package gtkglext-libs.x86_64 0:1.2.0-21.el7 will be installed
---> Package gts.x86_64 0:0.7.6-21.20111025.el7 will be installed
--> Processing Dependency: libnetpbm.so.11()(64bit) for package: gts-0.7.6-21.20111025.el7.x86_64
---> Package guile.x86_64 5:2.0.9-5.el7 will be installed
---> Package libXaw.x86_64 0:1.0.12-5.el7 will be installed
---> Package ocaml.x86_64 0:4.01.0-22.6.el7 will be installed
--> Processing Dependency: ocaml(Unix) = 93736a394d3d85d6d127fe238ddc6092 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Sys) = 5acfec22153eb1403597926ecd15f4f5 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(String) = db7f34081ef8fcaf499f19523d0736c6 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Set) = be044b48f40a48f0eb210225f11e0118 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Scanf) = 32f4f4bcda9cec7e02ee159052050f07 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Queue) = 2dece812a038a26a3231548f436037b6 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Printf) = d012329cc712e91d0f10a5eef2303d18 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Printexc) = d81cbca604b811d25138fa79499fe071 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Obj) = b0adfa4175f86e4394859886c1a374bb for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Map) = f11d7ddcffad09397202a49bd9bb4283 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(List) = d757117653d9319fefb7ddc78a998f41 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Lexing) = 50598ab7c92b4bdcc624e472342ac8a9 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Lazy) = 12a7b23bd30e5e207ddae39c8e41a1d2 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Int32) = ad06f04cfca6d404d1de76c3dc67324a for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 024edc3512403b725052aec8e41ed971 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Format) = e0d18776d4bacff3a198b5c23d0e9355 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Filename) = 28728bb478e079cce0b0c694de7944d6 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Digest) = 5972f410cf78f5813a94ff7b90804058 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Char) = 9554e5449c177414a27e7d7ff5ed8013 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(CamlinternalLazy) = 8f3f61657b86fd4738ffcd8e2cd074ea for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Buffer) = af3ef6fba94cdb4eba31e98b4e341dab for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Array) = 8a6bb22925744456eb66180ea42e3344 for package: ocaml-4.01.0-22.6.el7.x86_64
--> Processing Dependency: ocaml(Arg) = a7ebc43608a0326f6aa67069897d89e7 for package: ocaml-4.01.0-22.6.el7.x86_64
---> Package php-cli.x86_64 0:5.4.16-36.el7_1 will be installed
--> Processing Dependency: php-common(x86-64) = 5.4.16-36.el7_1 for package: php-cli-5.4.16-36.el7_1.x86_64
---> Package qt.x86_64 1:4.8.5-11.el7 will be installed
--> Processing Dependency: qt-settings for package: 1:qt-4.8.5-11.el7.x86_64
---> Package qt-x11.x86_64 1:4.8.5-11.el7 will be installed
--> Processing Dependency: libmng.so.1()(64bit) for package: 1:qt-x11-4.8.5-11.el7.x86_64
---> Package ruby.x86_64 0:2.0.0.598-25.el7_1 will be installed
--> Processing Dependency: rubygem(bigdecimal) >= 1.2.0 for package: ruby-2.0.0.598-25.el7_1.x86_64
--> Processing Dependency: ruby(rubygems) >= 2.0.14 for package: ruby-2.0.0.598-25.el7_1.x86_64
---> Package ruby-libs.x86_64 0:2.0.0.598-25.el7_1 will be installed
---> Package tcl.x86_64 1:8.5.13-8.el7 will be installed
---> Package tk.x86_64 1:8.5.13-6.el7 will be installed
--> Running transaction check
---> Package compat-poppler022.x86_64 0:0.22.5-4.el7 will be installed
---> Package graphviz-lang-ocaml.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(runtime) = 4.00.1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
---> Package libmng.x86_64 0:1.0.10-14.el7 will be installed
---> Package netpbm.x86_64 0:10.61.02-9.el7 will be installed
---> Package ocaml-runtime.x86_64 0:4.01.0-22.6.el7 will be installed
--> Processing Dependency: ocaml(Longident) = 1802b7b3176997a3efbccb3f3d8a3571 for package: ocaml-runtime-4.01.0-22.6.el7.x86_64
---> Package php-common.x86_64 0:5.4.16-36.el7_1 will be installed
--> Processing Dependency: libzip.so.2()(64bit) for package: php-common-5.4.16-36.el7_1.x86_64
---> Package qt-settings.noarch 0:19-23.5.el7.centos will be installed
---> Package rubygem-bigdecimal.x86_64 0:1.2.0-25.el7_1 will be installed
---> Package rubygems.noarch 0:2.0.14-25.el7_1 will be installed
--> Processing Dependency: rubygem(rdoc) >= 4.0.0 for package: rubygems-2.0.14-25.el7_1.noarch
--> Processing Dependency: rubygem(psych) >= 2.0.0 for package: rubygems-2.0.14-25.el7_1.noarch
--> Processing Dependency: rubygem(io-console) >= 0.4.2 for package: rubygems-2.0.14-25.el7_1.noarch
--> Running transaction check
---> Package graphviz-lang-ocaml.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(runtime) = 4.00.1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
---> Package libzip.x86_64 0:0.10.1-8.el7 will be installed
---> Package ocaml-compiler-libs.x86_64 0:4.01.0-22.6.el7 will be installed
---> Package rubygem-io-console.x86_64 0:0.4.2-25.el7_1 will be installed
---> Package rubygem-psych.x86_64 0:2.0.0-25.el7_1 will be installed
--> Processing Dependency: libyaml-0.so.2()(64bit) for package: rubygem-psych-2.0.0-25.el7_1.x86_64
---> Package rubygem-rdoc.noarch 0:4.0.0-25.el7_1 will be installed
--> Processing Dependency: ruby(irb) = 2.0.0.598 for package: rubygem-rdoc-4.0.0-25.el7_1.noarch
--> Processing Dependency: rubygem(json) >= 1.7.7 for package: rubygem-rdoc-4.0.0-25.el7_1.noarch
--> Running transaction check
---> Package graphviz-lang-ocaml.x86_64 0:2.38.0-1.el7 will be installed
--> Processing Dependency: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(runtime) = 4.00.1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31 for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
--> Processing Dependency: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde for package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64
---> Package libyaml.x86_64 0:0.1.4-11.el7_0 will be installed
---> Package ruby-irb.noarch 0:2.0.0.598-25.el7_1 will be installed
---> Package rubygem-json.x86_64 0:1.7.7-25.el7_1 will be installed
--> Finished Dependency Resolution
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Hashtbl) = 024edc3512403b725052aec8e41ed971
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Array) = 8a6bb22925744456eb66180ea42e3344
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(List) = d757117653d9319fefb7ddc78a998f41
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(runtime) = 4.00.1
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(runtime) = 4.01.1
ocaml(runtime) = 4.01.0
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Gc) = 292a1cd61d8e068943589882415bdf7d
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Obj) = b0adfa4175f86e4394859886c1a374bb
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Int32) = ad06f04cfca6d404d1de76c3dc67324a
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(List) = bd7c662c09e850306a62c12fed5ef5ce
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(List) = d757117653d9319fefb7ddc78a998f41
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Callback) = 6fd6d47b2f6a171a493621bc5edbfb32
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Callback) = 198fb4bcde892143b0866b03cfae8085
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Hashtbl) = 718cd6ce8bc18371ce22483e362f78b4
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Hashtbl) = 024edc3512403b725052aec8e41ed971
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Pervasives) = 4836c254f0eacad92fbf67abc525fdda
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Pervasives) = 36b5bc8227dc9914c6d9fd9bdcfadb45
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Array) = 4d5efba91ec70acd7b184fd4b277708c
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Array) = 8a6bb22925744456eb66180ea42e3344
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(runtime) = 4.00.1
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(runtime) = 4.01.1
ocaml(runtime) = 4.01.0
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Int32) = 265928798c0b8a63fa48cf9ac202f0ce
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Int32) = ad06f04cfca6d404d1de76c3dc67324a
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Gc) = 23b8d067f883f7a218c4945a42625a31
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Gc) = 292a1cd61d8e068943589882415bdf7d
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde
Available: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Int64) = 3945db6e8df0d5a79bcbc949ee550d52
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Obj) = ad977b422bbde52cd6cd3b9d04d71db1
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Obj) = b0adfa4175f86e4394859886c1a374bb
Error: Package: graphviz-lang-ocaml-2.38.0-1.el7.x86_64 (graphviz-stable)
Requires: ocaml(Int64) = 0d5ecd8dffcffac43aec2ebe427d3bde
Installing: ocaml-runtime-4.01.0-22.6.el7.x86_64 (base)
ocaml(Int64) = 3945db6e8df0d5a79bcbc949ee550d52
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

re: Graphviz stable on CentOS 7 64bits

It sounds like you might have some other version of graphviz installed that is causing unresolvable conflicts.  Could you try
 completely removing any prior versions first?   Perhaps with:

      rpm -qa | grep graphviz | xargs rpm -e

Also,  its been a long time since we released a stable version of graphviz.  You might have more luck with one of the recent snaphots.

re: Graphviz stable on CentOS 7 64bits

Thank you for your answer.
Unfortunately, no other previous version of graphviz is already installed ("rpm -qa | grep graphviz"  displays nothing)

Is there any repo file to grab a more recent snapshot ?

Thanks

 

Its in the same repo file

Its in the same repo file from http://www.graphviz.org/graphviz-rhel.repo

Just edit the snapshot section so that "enabled=1", and correspondingly disable the stable section.

re: Graphviz stable on CentOS 7 64bits

Ok, thank you so much! The installation did work ! Strangely enough, the installed version is not 2.39 but 2.30 (neato - graphviz version 2.30.1 (20150306.0020)). Isn't it strange for a snapshot version, or is there a way to get the latest editing the repo file ?

More problematic for me is that this version does not contain the triangulation lib (if I can remember this lib was in the epel repo, which is defined in my yum.repo.d/ folder and epel-release-7-5.noarch is already installed)

Would you have any lead ?

Thank you!

sfdp -Goverlap=prism -Gcharset=utf8 gvmap.gv  | gvmap -c 6 -c_opacity=4a | neato -Estyle=invis -Ecolor="#55555522" -n2 -Tsvg >goto.svg

Warning: Overlap value "prism" unsupported - ignored
Error: remove_overlap: Graphviz not built with triangulation library
Error: remove_overlap: Graphviz not built with triangulation library
Error: remove_overlap: Graphviz not built with triangulation library
Error: remove_overlap: Graphviz not built with triangulation library
Error: remove_overlap: Graphviz not built with triangulation library
Error: remove_overlap: Graphviz not built with triangulation library
Error: remove_overlap: Graphviz not built with triangulation library
 HERE!
Error: get_triangles: Graphviz built without any triangulation library

 

 

Recent comments