graphviz IE tooltip issue

Hi,

This i my sample file 

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
 "http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">
<!-- Generated by graphviz version 2.35.0 (20130914.0155)
 -->
<!-- Title: %3 Pages: 1 -->
<svg width="62pt" height="116pt"
 viewBox="0.00 0.00 62.00 116.00" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink">
<g id="graph0" class="graph" transform="scale(1 1) rotate(0) translate(4 112)">
<title>%3</title>
<polygon fill="white" stroke="white" points="-4,4 -4,-112 58,-112 58,4 -4,4"/>
<!-- a -->
<g id="node1" class="node"><title>a</title>
<g id="a_node1"><a xlink:title="Office 555&#45;122">
<ellipse fill="lightgrey" stroke="black" cx="27" cy="-90" rx="27" ry="18"/>
<text text-anchor="middle" x="27" y="-86.3" font-family="Times,serif" font-size="14.00">a</text>
</a>
</g>
</g>
<!-- b -->
<g id="node2" class="node"><title>b</title>
<g id="a_node2"><a xlink:title="Another office 555&#45;122">
<polygon fill="white" stroke="black" points="54,-36 0,-36 0,-0 54,-0 54,-36"/>
<text text-anchor="middle" x="27" y="-14.3" font-family="Times,serif" font-size="14.00">b</text>
</a>
</g>
</g>
<!-- a&#45;&gt;b -->
<g id="edge1" class="edge"><title>a&#45;&gt;b</title>
<path fill="none" stroke="black" d="M27,-71.6966C27,-63.9827 27,-54.7125 27,-46.1124"/>
<polygon fill="black" stroke="black" points="30.5001,-46.1043 27,-36.1043 23.5001,-46.1044 30.5001,-46.1043"/>
</g>
</g>
</svg>

 

<g id="node2" class="node"><title>b</title>
<g id="a_node2"><a xlink:title="Another office 555&#45;122">

Here when I do a mouseover on node2 i.e. 'b' in IE, I am seeing the same 'b' as tooltip instead of 'Another office 555-122'

 

If I change title in

<g id="node2" class="node"><title>b</title>

to some other thing say 'test tooltip' it is getting reflected in IE also.

How to change the value of title in

<g id="node2" class="node"><title>b</title>

through program. ?

Please guide.

The svg you posted looks

The svg you posted looks correct and when I view it using Chrome, Firefox and Safari, both nodes a and b show the correct tooltip. The only way to attach a tooltip to a node is to use the tooltip attribute (or the equivalent in HTML-like labels).

Can you try in IE. That is

Can you try in IE. That is where I have problem.

Unfortunately, I don't have

Unfortunately, I don't have access to IE.

That is strange no access to

That is strange no access to IE?BitCoin VPN

Some of us only work in Linux

Some of us only work in Linux or OSX, and avoid Windows products. :)

Recent comments