2.28 compile error

I am trying to compile 2.28 from source code on a CentOS5.3, but I got this error " ui_settings.h:32: error: expected constructor, destructor, or type conversion before ‘class’".

Has anybody seen this?

Thanks,

Mi

.so: Unsatisfied data symbol 'Dtoset' in libgvc.so.6

I am trying to compile 2.28 from source code on a hp-unix ,I had builded。But when i call the lib of graph with JNI. Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/frontmon/gv/gv_layout_adaptor/src/libgv_layout_adaptor.so: Unsatisfied data symbol 'Dtoset' in load module '/home/frontmon/gv/build/lib/libgvc.so.6'. at java.lang.ClassLoader$NativeLibrary.load(Native Method) at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1751) at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1676) at java.lang.Runtime.loadLibrary0(Runtime.java:823) at java.lang.System.loadLibrary(System.java:1030) at com.ultrapower.digraph.layout.GvLayoutAdaptor.(GvLayoutAdaptor.java:19) at com.ultrapower.TestDLL.loadApp(TestDLL.java:36) at com.ultrapower.TestDLL.main(TestDLL.java:31)

Yup

 Yup I'm dealing with it.

Recent comments