alignment

cluster problem with manual positions

Hello Everybody!

I'm writing my thesis and just found graphviz a few days ago, so consider me an absolute beginner. I was able to create almost everything needed, but I do have a problem with this, not getting the cluster:

graph G {
node[shape = circle , height =.6, fixedsize= true];
i[pos="0,0"];
j[pos="80,0"];
x1[pos="160,0"];
xm[pos="290,0"];
ii[pos="370,0",label=i];
jj[pos="450,0",label=j];
subgraph cluster_0 {
x1--xm[style=dotted];
}
i--j[dir=forward];
j --x1[dir=forward];
xm--ii[dir=forward];
ii--jj[dir=forward];
}

align problem in record

how can I align all lines with the left side of the record node?

this is a simple example of my problem
http://dl.dropbox.com/u/2196861/align.PNG

and this is a my simple code
n2 [label = "this is line1\ncan I align with the left side\nline3"];

I want to align all lines with the left side,and
I try to use 'nojustify = "true"' or 'labeljust = "l"',
but I can't solve it.

how can I do?

by the way,when I output a picture to .svg format ,the text will exceed the bound of node.
and when I change to .png format ,this problem is not exist.
why??

like this:

Align at left side of nodes

hi all, I want to use graphviz for recording the callpath in my code reading, and I like to use "rankdir=LR" to arrange the function hierachy. Here my question is, how to align the nodes by its left side? it looks that the default alignment of nodes is "center".
I show an example like below:
============================================

Recent comments

Syndicate content