Number: 1812
Title: No working python libraries in OS X Snow Leopard
Submitter: Terry Wilson
Date: Mon Nov 9 09:06:05 2009
Subsys: Other
Version: 2.25.20091109.0545
System: x86-OSX-10.6
Severity: minor
Problem:
Their are directories under /usr/local/lib/graphviz for python, python2[3-6]. Only the 'python' directory has any libraries, but unfortunately they cause a crash due to (I presume) being for the wrong version of python. The error:

>>> >>> sys.path.append('/usr/local/lib/graphviz/python/')
>>> >>> import gv
Fatal Python error: Interpreter not initialized (version mismatch?)
Abort trap

A popup window then comes up saying "Python quit unexpectedly while using the _gv.so plug-in."
Comments:
[ellson] This is probably a consequence of our building on Leopard. I guess I'll just have to set up a separate build host for SnowLeopard :-(
Owner: arif
Status: *